Your Universal Remote Control Center
RS-232 & IP Control Forum - View Post
Previous section Next section Up level
Up level
The following page was printed from


ADA Suite 16 with Pronto Pro
This thread has 1 response. Displaying all posts.
Post 1 made on Monday February 12, 2024 at 19:46
Marcus Wood
Long Time Member
July 2003
I recently bought a used ADA Suite 16 which I'm trying to control with a Philips Pronto Pro system, but I can't get this to work.

Well, the Rx LED comes on when I send an RS232 command but that's all that happens. The Rx light also comes on if you send a command that's meant for another device.

I have the Suite 16 manual, and I've followed the instructions and copied the commands in that as I understand them. The baud rate is 19200 baud with 8 Data Bits, 1 stop bit, and no parity.

Commands for the Suite 16 are ASCII and the first character is the ` symbol (on the key to the left of '1') and the last 'character is , which I assume is just the enter key. For example 'volume up' is: ‘SVLUPR01[carriage return]

I've tried connecting the RS232 cable direct from the Pronto Extender to the Suite 16 and also via a ISO-CAT II.

I have another ADA pre-amp (a Mach III) that works fine with RS232 via the Pronto but on that I had to do a factory default reset via the front panel controls before the RS232 would work. I've tried sending a RS232 reset command to the Suite 16, but that doesn't help. By the way, the Mach III uses completely different commands (hex).

The Suite 16 passes audio signals OK on the input and output it's currently set to, neither of which I can change...

Can anyone suggest where I might be going wrong?

Last edited by Marcus Wood on March 30, 2024 09:13.
OP | Post 2 made on Saturday March 30, 2024 at 09:32
Marcus Wood
Long Time Member
July 2003
I eventually got this working.

First I checked that there wasn't a hardware fault. A friend who's a computer programmer connected the Suite 16 to a PC and sent the text commands in the ADA documentation from that, which worked fine (we could hear relays clicking and the LEDs changing). After that we also send a 'reset to factory defaults' RS232 command, also in the ADA manual which may have helped. (Thanks Stuart!).

So then I knew the problem was related to the Pronto system. I had a feeling that it was something to do with the carriage return 'character'. It looked to me like ProntoEdit wasn't treating carriage return as a character because when I went into the command codes I'd already typed in and hit 'end' the cursor was immediately to the right of the character before carriage return, in the same way as if I'd never typed carriage return.

When I was asking my friend about the carriage return command he had mentioned that in hex, carriage return has a specific character code.

So I tried translating all the text commands in the ADA set up document to Hex using an online translator. The `character translates as: 60. The translator didn't convert 'carriage return' correctly, but I found elsewhere that it's: 0D.

Once I converted the commands to hex, everything worked perfectly!

So the 'volume up room 1' command above is: 60 53 56 4C 55 50 52 30 31 0D

By the way I also have a Suite 8x8 which I also couldn't get to work, and I got that working in exactly the same way as I did with the Suite 16. It seems to use the same commands too - it's best to use the list of commands in the Suite 16 manual because the 8x8 manual is somewhat sketchy.

Jump to

Protected Feature Before you can reply to a message...
You must first register for a Remote Central user account - it's fast and free! Or, if you already have an account, please login now.

Please read the following: Unsolicited commercial advertisements are absolutely not permitted on this forum. Other private buy & sell messages should be posted to our Marketplace. For information on how to advertise your service or product click here. Remote Central reserves the right to remove or modify any post that is deemed inappropriate.

Hosting Services by ipHouse