Your Universal Remote Control Center
RS-232 & IP Control Forum - View Post
Previous section Next section Up level
Up level
The following page was printed from


[Solved] Samsung C43J890DK - Updated with wrong firmware
This thread has no replies.
Post 1 made on Wednesday January 24, 2024 at 15:58
New Member
January 2024
Took the right firmware m-J8943cgaa-1006.2[FF21].bin and changed the filename to m-J8949cgaa-0000.0[FF21].bin the same way how I started the hole mess.

With renaming the version name 0000.0 you can force a downgrade or skip the version check.

Started the update process as described in the manual and it worked.
Fixed the monitor

Hello folks
I recently tried to update my business monitor. It's a Samsung C43J890DK.
I downloaded the firmware from [Link:]

The newest FW availlable is unfortunatly for the 49" version. I thought it was a typo and simply changed the filename from 49 to 43 and simply messed it up. Of course there is no picture anymore and I can't access the menu. When connected with my laptop, I see the monitor in windows.

Long story short, is there a possibilty to upload the correct FW ower the Ex-link port?
The availlable FW is a Bin-File. If it is possilble to upload the right FW, with which tool should I proceed?

Thank you in advance for any inputs and compliments for my big brain engineer thinking. #fafo#

Last edited by bobby6k on January 26, 2024 04:03.

Jump to

Protected Feature Before you can reply to a message...
You must first register for a Remote Central user account - it's fast and free! Or, if you already have an account, please login now.

Please read the following: Unsolicited commercial advertisements are absolutely not permitted on this forum. Other private buy & sell messages should be posted to our Marketplace. For information on how to advertise your service or product click here. Remote Central reserves the right to remove or modify any post that is deemed inappropriate.

Hosting Services by ipHouse