Your Universal Remote Control Center
RS-232 & IP Control Forum - View Post
Previous section Next section Up level
Up level
The following page was printed from


SOLVED: controlling viewsonic PX474-4K with RS232 - help!
This thread has 2 replies. Displaying all posts.
Post 1 made on Sunday March 10, 2019 at 18:32
Lurking Member
October 2012

Trying to control my Viewsonic PX747-4K via RS232 from a windows 10 PC.
I have a USb to RS232 cable (2 actually, 1 with profilic and one with FTDI cipset). Original so no copys :)

I have the manual which state what commands, baudrates etc should be used.
But I have no luck in controlling it at all.

I've uset, realterm, termite, putty, device monitoring studio, 232Analyzer etc, but the only one I've had success at all with is REALTERM and 9600baud.
If I send the HEX for ON which in the manual is 06 14 00 04 00 34 11 00 00 5D
It responds with 01 14 00 00 00 14

A correct response should be 03 14 00 00 00 14 and the projector starting up :)

I'm at my wits end and has tried finding a solution for this for several days and must no ask for help.

I've attached 2 PDFs, one for my projector, and one other for viewsonics projects in general.

Could someone please point me in the right direction or troubleshoot it?
I know there is nothing wrong with the projector as I've tried another one and I have the same problem which means its ME and not the projector that sucks :(

Thanks in advance!

Last edited by sintei on February 22, 2021 07:53.
OP | Post 2 made on Monday March 11, 2019 at 08:44
Lurking Member
October 2012
Funny, It seems some commands actually work.
I can change how the svreen is projected (ie front or ceiling)
Rear Ceiling
06 14 00 04 00 34 12 00 02 60

06 14 00 04 00 34 12 00 00 5E

But setting picture mode is not what it says it should be in the manual.
the below should be "Picture mode movie" but is really "standard"
06 14 00 04 00 34 12 0B 01 6A

And this one should be "Picture mode standard" but is actually "User1"
06 14 00 04 00 34 12 0B 04 6D
OP | Post 3 made on Monday February 22, 2021 at 07:53
Lurking Member
October 2012
Digging up an old post of mine.
But hey, I solved the problem and anyone else coming here might benefit.

My projector is assembled in May 2018.
In July 2018 viewsonic actually changed their RS232 codes to another version, which is the one written in the manuals.

This took me 2 years and viewsonic europe themselves could not help me.
They even "repaired" the unit saying it was faulty (which obviously it wasn't).
In the end they blamed my software and hardware and they could not help me.
Even though I actually used their own software (vcontroller) and I could partially controll the projector. RS232 is only TX/RX/GND in this case, so if it was hardware related, I would not even be able to send one command and receive an response.

Oh well.. it works now, but next time I'll consider another manufaturer due to the bad support and I had to solve the problem myself..

Conclusion: There is an old library where the codes are like this:
ASCII: *pow=on#
HEX: 0D 2A 70 6F 77 3D 6F 6E 23 0

Jump to

Protected Feature Before you can reply to a message...
You must first register for a Remote Central user account - it's fast and free! Or, if you already have an account, please login now.

Please read the following: Unsolicited commercial advertisements are absolutely not permitted on this forum. Other private buy & sell messages should be posted to our Marketplace. For information on how to advertise your service or product click here. Remote Central reserves the right to remove or modify any post that is deemed inappropriate.

Hosting Services by ipHouse