Your Universal Remote Control Center
Displays & Projectors Forum - View Post
Previous section Next section Up level
Up level
The following page was printed from


Plc-xe40 projector
This thread has no replies.
Post 1 made on Friday March 16, 2018 at 05:25
Lurking Member
March 2018
So this is my first post, so HI all

So iv been given two Sanyo Plc-xe40 projectors, and I can't get one of them to fire up.
My biggest problem is that iv not got any remotes for them, and if you aren't aware these projectors don't have any external buttons on them.
Iv tried a application called Zaza universal remote, but still nothing.

Iv checked some of the standard problems eg lamp looks fine, lamp cover micro sw is fine, thermal cutout is fine, iv checked the power board and all voltages are good.

On the main board there are places for push button switches to be placed on, iv tried linking these out but still nothing.

Or can anyone help with other things that I should be checking.

Iv looked over the files part of this site but unsure on how I could duplicate a remote from the site so any help would be grateful.

Jump to

Protected Feature Before you can reply to a message...
You must first register for a Remote Central user account - it's fast and free! Or, if you already have an account, please login now.

Please read the following: Unsolicited commercial advertisements are absolutely not permitted on this forum. Other private buy & sell messages should be posted to our Marketplace. For information on how to advertise your service or product click here. Remote Central reserves the right to remove or modify any post that is deemed inappropriate.

Hosting Services by ipHouse