Your Universal Remote Control Center
RS-232 & IP Control Forum - View Post
Up level
Up level
The following page was printed from


Original thread:
Post 1 made on Tuesday March 15, 2022 at 18:32
Junior Member
March 2022
So I recently got a Xantech HD44CC5 component video switcher. Didn't come with a remote, and to the bafflement of myself, has no buttons to control anything. I wanted to use it as a 4 in 1 out, but the default is a 4 out 1 in. It came with a little board to break the DB9 connector on the back into 5 pins, (GND, RX, TX, RTS and CTS)
I have been trying for weeks now to get this to work. I have had very limited success. I have installed like, 5 terminal programs, none of which seem to be super intuitive but maybe I'm the problem. anyway
The way I'm using to control it is an Arduino Uno board (technically a red board but I believe they're very very similar). I have 5v on ground, other ground going into that DB9 board i mentioned, and have tried rx-rx+tx-tx and rx-tx+tx-rx
Nothing has worked. I am at a loss. The drivers are installed, I can send commands (i think), the board has some response to the switcher flashing lights when it goes on and off, but no commands seem to be sent through.
I have 1byte hex codes (i think thats what they are) from Xantech's own universal dragon program, and they give some other wierd format in the manual
Tried em all, nothing works. If there's something here that you think might be the issue, let me know, I'm open to anything. Thanks a lot.

Hosting Services by ipHouse