Your Universal Remote Control Center
RS-232 & IP Control Forum - View Post
Up level
Up level
The following page was printed from


Original thread:
Post 94 made on Wednesday August 19, 2020 at 13:02
Lurking Member
June 2019

This is an awesome resource. Thank you all for putting this together and contributing to it. I can say Samsung makes great TVs but there is a lot to desire with regards to its support.

I have an installation that involves a few TVs of the following models: UN65TU8000FXZA (TU8000s of different sizes) and a QN85Q60TAFXZA. All of these TVs no longer have the 3.5mm Ex-Link port we were expecting to have.

From a communication from Samsung we understood USB was needed for control now, but Samsung buried the "USB Serial" setting in the service menu.

We use Kramer AV Controls to design our iPad custom programming. Kramer tells us Samsung and LG have gone the authentication route and they cannot support yet IP control. This leaves Serial control as a limited-reliable solution (no feedback as far as I know). IR is supported but it's the less desirable option.

We have tried all the suggestions in this thread with regards to getting USB Ex-Link working but we get no PowerOn or PowerOff or any command executed at all.

We are using a standard RS-232 cable (USB to DB9-F with a PL chip). I believe it's also called a TTL cable. We use a GlobalCache iTack IP2SL gateway (has a DB9-M port) to connect to TTL cable.

Service Mode settings: --RS-232 Jack: UART --EXT Link Support: ON --USB Serial: ON Hotel/Hospitality Mode: OFF
Standard settings: --AnyNet+: OFF
EX-Link com port settings: --9600 baud --8 bit --no parity --1 stop bit --no hardware flow control


When testing a direct serial connection from a laptop (with a USB to Serial dongle) and the Hercules utility, all we is "double-quotes" when we send the HEX codes from the XLS shared here for power-on, power-off or power-toggle.

To summarize, we have not been able to get ANY command successfully via Serial-USB to any of the TVs. Some have mentioned PowerOn only worked. That hasn't been our case.

If you can think of any thing that could be causing the total disconnect, please let me know.



Hosting Services by ipHouse