Your Universal Remote Control Center
RS-232 & IP Control Forum - View Post
Up level
Up level
The following page was printed from


Original thread:
Post 59 made on Monday April 17, 2017 at 09:49
Lurking Member
November 2016
On April 3, 2017 at 00:18, impala454 said...
I've been following this thread and actually got several codes working on my Sammy HLS6187W (which has an actual DB9 for the RS232 port). Odd thing is now, I'm not sure what happened but they stopped working and now I get a single byte response of 0xfd. I've tried factory resetting the TV, turning both PC and TV on/off, reseating the cable, writing the code in different languages (C# and Python). For the life of me I can't figure it out. I did go into the service menu and choose Debug for the RS232 mode. Any other suggestions?

I've got the same issue. Worked fine and at some moment for unknown reason my TV Samsung UE37C6000 stopped working via Ex-Link/RS232 port, while the controller program has not changed.
I tried to change the port and swap the cable, performed TV factory reset, tried all possible setting at service menu with no result. TV doesn't accept the HEX commands, however when I change the port mode from UART to Debug I can see the response/logs from my TV at terminal window.

Will let you know if I found solution

Hosting Services by ipHouse