Your Universal Remote Control Center
Complete Control by URC Forum - View Post
Up level
Up level
The following page was printed from


Original thread:
Post 1 made on Saturday July 18, 2015 at 22:47
Founding Member
January 2002
I thought this would be somewhat straight forward since I was abel to get it working on Windows 7, 8 and 8.1, but it's not. When I went to install the driver, it kept giving me an error stating "The Hash for the File is not Present in the Specified Catalog File".

After looking around, I found that I had to disable the Driver Signature Enforcement on Windows 10. To do this, I followed a page a found on that described how to do this(I cut and pasted how to disable the Driver checking part directly from the page that was to install an Apple network driver on Windows 10)...

Go to start and type ‘advanced’ and click ‘change advanced startup options’
At advanced start up, choose restart now.

On the blue boot screen you click:
Troubleshoot, Advanced options, Startup Settings -> restart.

When rebooted choose the 7th bullet “Disable driver signature enforcement”.

I installed the MX-810 driver, as I did for Windows 7 and 8.1...

After the reboot, go into Device Manager(after plugging in the MX-810), right click on the Unknown device and click "Update Driver".
Select "Browse My Computer" and drill to C:\Program Files (x86)\Universal Remote Control, Inc\MX-810 ProWizard\drivers\Windows Vista\64-bits directory.
It should show it is installing for the URC USB Sync FW1 device. When the warning appears choose "Install the driver anyway" and it should install.

Without disabling the Driver Signature Enforcement" the driver would not install for me. I have been working through all my devices, making sure they work on Windows 10 and this one was a hold up for me.

As an FYI, the is on the RTM version of Windows 10.

Hosting Services by ipHouse