Your Universal Remote Control Center
RemoteCentral.com
UEI Nevo Remote Controls Forum - View Post
Previous section Next section Previous page Next page Up level
Up level
The following page was printed from RemoteCentral.com:

Login:
Pass:
 
 

Page 5 of 5
Topic:
Its here!!!!!!
This thread has 72 replies. Displaying posts 61 through 73.
Post 61 made on Wednesday March 31, 2010 at 19:40
Cymon
Lurking Member
Joined:
Posts:
March 2010
3
Hi Syd,

I would like to know where'd you find the right string of command to isolate the two variable for the volume feedback from the Integra
HDMI: Highly Deficient Media Interface
Post 62 made on Thursday April 1, 2010 at 14:00
Ry-dog
Long Time Member
Joined:
Posts:
July 2005
169
On March 31, 2010 at 11:56, veekay said...
Very nice. Everything works great when testing, but real world stuff still fails constantly - might have to try swapping out another NC50 and/or try a Q50 to see if one of these devices is faulty.

What did you mean by everything works great when testing? Are you talking about testing in the widget debugger or on the remote?

I haven't done much with serial or IP 2-way (just a little bit of tinkering with an Escient Fireball using both serial and IP on it), but everything has been working fine for me thus far. I have noticed that IP is DEFINITELY the way to go because the response times are dramatically quicker. When I send out commands to the Fireball through IP, the response shows up right away on the S70, but when I try the same commands through serial, there is a slight delay. It's probably just the nature of serial and IP, but I'm definitely going to go with IP where ever I can.
Post 63 made on Thursday April 1, 2010 at 19:00
veekay
Long Time Member
Joined:
Posts:
October 2009
27
Testing in both the debugger and emulator. Real world does nothing except occasionally sets the volume when I move the slider.
Post 64 made on Saturday April 3, 2010 at 01:48
veekay
Long Time Member
Joined:
Posts:
October 2009
27
Updated Widgets PDF - not sure what has been changed.

New actual widgets as well.
Post 65 made on Monday April 5, 2010 at 00:54
sydinstaller
Active Member
Joined:
Posts:
February 2004
738
Cymon,

I don't understand you grestion.

What command do you mean? the rs232 question or the filter?

D.
Post 66 made on Monday April 5, 2010 at 16:00
Cymon
Lurking Member
Joined:
Posts:
March 2010
3
Hi Syd,

the question I'm askering you is the regex in the filter

Thanks
HDMI: Highly Deficient Media Interface
Post 67 made on Monday April 5, 2010 at 18:20
sydinstaller
Active Member
Joined:
Posts:
February 2004
738
Hi,

So I spent some time learning about RegEx. Here are two sites that really helped.

[Link: addedbytes.com]

[Link: regexlib.com]

Also Wikipedia and some other random sites.

Here is the breakdown of the volume RegEx (?<=!1MVL)[A-Fa-f0-9]{1,2}

(?<=!1MVL)
This is a look behind assertion. It will look for and match !1MVL

[A-Fa-f0-9]
This is now looking for a HEX character following !1MVL

{1,2}
This bit is say to look for 1 or 2 matches of the HEX character.

So it the amp was to reply with:
!1MVL4F
the above RegEx would match 4F. This is then converted into decimal 79. So the amp is set to a volume level of 79.

RegEx is sensitive to CAPS so that is why the RegEx has A-Fa-f, this will cope with an amp that shows as small caps or large CAPS.

Also the !1MVL, in the case of Integra, will only work if it is in CAPS and !1mvl will not work.

Furthermore, when testing using the second site do not have any extra spaces (white gaps) or carriage returns or line feeds in the test data window.

Finally, I have found that NSP does not like the /w /W /d /D switches.


D.
Post 68 made on Monday April 5, 2010 at 18:50
Cymon
Lurking Member
Joined:
Posts:
March 2010
3
Hi Syd,

Thank you very much, it's very helpful
HDMI: Highly Deficient Media Interface
Post 69 made on Wednesday April 14, 2010 at 01:59
veekay
Long Time Member
Joined:
Posts:
October 2009
27
Has anyone had luck with the volume feedback to get half numbers as well? It seems I can't get it to report say 35.5 for the volume, just 35 or 36.
Post 70 made on Wednesday April 14, 2010 at 04:55
sydinstaller
Active Member
Joined:
Posts:
February 2004
738
If you look at the RS232 document from Integra you will notice that it does not support .5 steps.

D.
Post 71 made on Friday July 2, 2010 at 10:19
Koncept
Junior Member
Joined:
Posts:
July 2010
2
I need your Help !!!

I was using Nevostudio 2.0 on my Windows XP Station.

But now i'm on Windows 7 and Nevostudio 2.0 won't work.

So i could not update NevoStudio 2.0 because it won't work and don't download NST 3 on Nevo WebSite because i'm not register.

Does anyone can send me NevoStudio 3.0 by private message ?

Thanks a lot !

(excuse my english, i'm french !!)
Post 72 made on Friday July 2, 2010 at 13:37
brodyboy
Long Time Member
Joined:
Posts:
April 2008
360
From the XP workstation where you have NSP 2.0 running, register on the Nevo website. Then log on from your new computer and simply download NSP 3.0.
Post 73 made on Monday July 5, 2010 at 17:43
Koncept
Junior Member
Joined:
Posts:
July 2010
2
OK thanks Brodyboy !!
It was so easy !!!!
Find in this thread:
Page 5 of 5


Jump to


Protected Feature Before you can reply to a message...
You must first register for a Remote Central user account - it's fast and free! Or, if you already have an account, please login now.

Please read the following: Unsolicited commercial advertisements are absolutely not permitted on this forum. Other private buy & sell messages should be posted to our Marketplace. For information on how to advertise your service or product click here. Remote Central reserves the right to remove or modify any post that is deemed inappropriate.

Hosting Services by ipHouse