Your Universal Remote Control Center
RemoteCentral.com
Complete Control by URC Forum - View Post
Previous section Next section Previous page Next page Up level
Up level
The following page was printed from RemoteCentral.com:

Login:
Pass:
 
 

Page 2 of 2
Topic:
URC PIR-1 IR Learning Not Working
This thread has 16 replies. Displaying posts 16 through 17.
OP | Post 16 made on Sunday April 8, 2018 at 17:07
zorax2
Long Time Member
Joined:
Posts:
July 2003
19
I just got the PIR-1 to work with Windows 10 Professional!!! It took me hours to do so but at least I got it to work.

Here are the steps in case someone else needs to do this:

1. Use Windows 7 native or in a Virtual Computer to upgrade the PIR-1 firmware. CCP updated the firmware on my PIR-1 to v 1.54 and then another update to v 1.56. (You might get lucky and have this work on Windows 10 which will save time).

2. Got to the FTDI website and download the updated drivers 2.12.28.0 from 08/16/2017.

3. Plug the PIR-1 into a USB port.

4. Go to device manager and you will find it adds a USB Serial Port Driver and a USB Serial Converter. Double click on each of these (one at a time), go to the Driver Tab and click update driver. Go to the directory where you downloaded the FTDI driver and update the drivers.

While the PIR-1 now works in CCP via Win 10, it does have a quirk. When you go to macro and select IR learning, you will get an error message "An unsupported operation was attempted". Close that message and the PIR-1 will appear in a ready to learn state.

I'm curious as to whether goldenzrule's PIR-10 will work out of the box with Win 10 or if he'll have to do the driver updates like I did. In any event, THANK YOU goldenzrule for giving me some more information to help me troubleshoot and figure it out.

I wish URC would publish something or directly provide the drivers as part of the CCP update or alternatively better integrate the PIR-1 into their software.
Post 17 made on Sunday April 8, 2018 at 18:55
goldenzrule
Loyal Member
Joined:
Posts:
July 2007
7,639
Awesome. Glad you got it going. I didn't get to test in win10 yet. I was out most of the day and then installed a new mailbox post for our house when I got home. Just got inside. I'm frozen. It's April, what's up with that?
Page 2 of 2

Jump to


Protected Feature Before you can reply to a message...
You must first register for a Remote Central user account - it's fast and free! Or, if you already have an account, please login now.

Please read the following: Unsolicited commercial advertisements are absolutely not permitted on this forum. Other private buy & sell messages should be posted to our Marketplace. For information on how to advertise your service or product click here. Remote Central reserves the right to remove or modify any post that is deemed inappropriate.

Hosting Services by ipHouse