Your Universal Remote Control Center
Philips Pronto NG Family Forum - View Post
Up level
Up level
The following page was printed from


Original thread:
Post 1 made on Wednesday June 20, 2018 at 07:11
Long Time Member
November 2003
Running ProntoProEdit NG on Windows XP Pro (via Parallels VM on a MacBook Pro). PPENG had run for several years without problems until the computer's battery had to be disconnected while in for repair.

Initially the warning was that a driver was missing but that stopped after we uninstalled PPENG using the proper Windows Uninstall procedure and reinstalling.

We closed Windows and relaunched it along with PPENG; tried to upload data from Pronto RU990 and got this message:
“(ProntoProEdit NG) Device is not connected properly. Please check the connection.” Anything else we try brings up the same message.

We have tried using a different USB cable and both worked with other devices as well as the Pronto, so it seems the cable is good and that the problem is in the software.

From RC's troubleshooting FAQs:
"4 - The remote’s communications chip has locked up (sometimes occurs during code learning through ProntoEdit NG) – reboot the remote by pressing the RESET button on the back.”
Tried that and got audible response from computer, so it seems the physical connection is OK but still got the "not connected" warning.

We had also remembered to go to “Devices/USB/Philips Vendor specific”

We’ve tried uninstalling and reinstalling more than once as well as everything else we can think of, so any other suggestions would be gratefully received.

Last edited by Caz on June 20, 2018 11:06.

Hosting Services by ipHouse