Your Universal Remote Control Center
Philips Pronto Classic Forum - View Post
Up level
Up level
The following page was printed from


Original thread:
Post 5 made on Friday May 15, 2020 at 09:53
Long Time Member
February 2009
Fixed it !!
I would accuse myself of muppetry of the highest order but for the explanation that follows....
I took the battery pack out of one of my other fully operational RC9200s (This RC9200 had been sat in it's charging cradle) and fitted it to my new RC9200. The behaviour of the new RC9200 was something I've never seen before and is described in my OP. As a last resort I dismantled the remote and reseated cables etc - everything looked physically fine. I reassembled it but still the same issue. That's it I thought - no joy, and put the battery back in the other remote. I was perplexed when IT didn't power either! Bottom line? - The battery was at fault !! when I put in another battery pack from yet another RC9200 of mine both remotes worked perfectly. The moral of this story is - make absolutely sure the battery is good. If the remote had been completely dead I might have tried another battery straight away - it was the strange behaviour that threw me. On reflection, I seem to remember the battery I used didn't hold it's charge very well. Perhaps I am a muppet after all !! ;- )

Hosting Services by ipHouse