Your Universal Remote Control Center
Philips Pronto Classic Forum - View Post
Up level
Up level
The following page was printed from


Original thread:
Post 1 made on Tuesday October 13, 2015 at 10:53
Lurking Member
October 2015
Having had nothing but problems with serial communications back and forth to my Pronto T-1000 using Windows 7, I decided to take a flyer and install ProntoEdit4 on my recently converted Windows 10 machine.

Be aware that I am using an older Windows 7 computer that I updated to Windows 10. This older motherboard does have a serial port connector on the motherboard header. I DID have to activate this port in the BIOS and set it to COM1. I have not tried this with any USB to Serial adapters installed, but I do have one, and may try it too. If I do, I'll report back with the model of adapter and the results.

Here are the steps I took;

I downloaded the Pronto edit V4 from Remote Central
I unzipped and ran the install program as an administrator using the compatibility checker and set compatibility to XP Service Pack 3.
After the program installed, I created an icon for ProntoEdit.exe on the desktop.
I right clicked the icon, and chose the “Properties” menu selection.
In the “Properties” dialog box, I clicked on the “Compatibility” tab.
I UNSELECTED “Run this program in compatibility mode for:”
I UNSELECTED “Run this program as an Administrator”

I have played with this extensively and all the functions seem to work perfectly including IR learn, and up and down loading configurations. The only tiny glitch I see is that when adding a button to a panel from the palette, the button image isn’t visible as you are dragging it, but becomes visible as soon as you “drop” it onto the panel. Then you can move it and see it while dragging just fine.

If I run it as an administrator, it crashes every time I try to do an IR Learn, so I make sure that "Run as Administrator" is off for the program, although it was ON for the installation program.

Hosting Services by ipHouse