Your Universal Remote Control Center
RemoteCentral.com
RS-232 & IP Control Forum - View Post
Previous section Next section Up level
Up level
The following page was printed from RemoteCentral.com:

Login:
Pass:
 
 

Topic:
Viewsonic RS232 What is missing?
This thread has 10 replies. Displaying all posts.
Post 1 made on Wednesday October 13, 2010 at 17:02
TouchCommander
Active Member
Joined:
Posts:
December 2004
534
On command

Header = BE EF 10 05 00
CRC = C6 FF
Command = 11 11 01 00 01 00
Responce = 06
Straight cable, but have tried null also

Baud is 19200
Parity none
Data Bit 8
Stop Bit 1
I try BE EF 10 05 00 C6 FF 11 11 01 00 01 00 06 enter
Try rearranging Header CRC etc.
Try different baud rates.
Viewsonic Tech's are clueless
Any help is appreciated!!!!
No job to small, many to big
Post 2 made on Wednesday October 13, 2010 at 17:42
gopronto
Senior Member
Joined:
Posts:
April 2008
1,436
do you have a copy of the protocol you can post?
Pronto still one of the best Wi-Fi Remotes,
www.ikonavs.co.nz and [Link: prontoprojects.com] Axium Control catching up fast :)
OP | Post 3 made on Wednesday October 13, 2010 at 18:24
TouchCommander
Active Member
Joined:
Posts:
December 2004
534
What I listed is verbatum what is published by viewsonic in the owners manual. The only change is that they have it listed as

CRC = BE EF 10 05 00
Header = C6 FF, but said that this was reversed.
No job to small, many to big
Post 4 made on Wednesday October 13, 2010 at 18:40
gopronto
Senior Member
Joined:
Posts:
April 2008
1,436
can you email me the manual
Pronto still one of the best Wi-Fi Remotes,
www.ikonavs.co.nz and [Link: prontoprojects.com] Axium Control catching up fast :)
OP | Post 5 made on Wednesday October 13, 2010 at 18:44
TouchCommander
Active Member
Joined:
Posts:
December 2004
534
email has been sent

Thanks
No job to small, many to big
Post 6 made on Wednesday October 13, 2010 at 18:49
gopronto
Senior Member
Joined:
Posts:
April 2008
1,436
try this to see if it turns the projector on
BE EF 10 05 00 C6 FF 11 11 01 00 01 00

you need to make sure you have the baud rate settings correct, these are set in the Projector menu.

Normally 19200 , 8 1 None

you should only need pins 2,3 and 5 connected
Pronto still one of the best Wi-Fi Remotes,
www.ikonavs.co.nz and [Link: prontoprojects.com] Axium Control catching up fast :)
OP | Post 7 made on Wednesday October 13, 2010 at 19:02
TouchCommander
Active Member
Joined:
Posts:
December 2004
534
Tech support said that there was no Baud rate setting in projector, but I bet there is. Tried your suggestion, no go. In hyper terminal do you select Xon, Xoff- hardware- or none in configure? Also do you use send line ends with line feed in AsCii setup?
No job to small, many to big
Post 8 made on Wednesday October 13, 2010 at 19:20
gopronto
Senior Member
Joined:
Posts:
April 2008
1,436
dont use hyper terminal , use Terminal by [email protected]++ you will find it on google
Pronto still one of the best Wi-Fi Remotes,
www.ikonavs.co.nz and [Link: prontoprojects.com] Axium Control catching up fast :)
OP | Post 9 made on Wednesday October 13, 2010 at 19:47
TouchCommander
Active Member
Joined:
Posts:
December 2004
534
Assume that command is entered at bottom of page? Can you select baud rates one right after another without having to do anything else?
No job to small, many to big
Post 10 made on Wednesday October 13, 2010 at 20:19
gopronto
Senior Member
Joined:
Posts:
April 2008
1,436
you just have to disconect and reconect each time you change the baud rate, im guessing it will be 19200, 8,n,1

to send hex in [email protected]++ terminal

the string will look like this

$BE$EF$10$05$00$C6$FF$11$11$01$00$01$00
Pronto still one of the best Wi-Fi Remotes,
www.ikonavs.co.nz and [Link: prontoprojects.com] Axium Control catching up fast :)
Post 11 made on Wednesday June 1, 2016 at 09:46
AlexShu
Junior Member
Joined:
Posts:
June 2016
1
I know this is 6 years old thread but I had the same problem and this page always pop-uped, so if any one will be reading this.

The solution for me:
I was using USB - TTL adapter (logic level 0V to 3.3V/5V) and its no good (Arduino, USB-Serial etc...)
then when I switched to RS-232 (-3~-25V to +3~+25V), Bam! Works:)

I used the native COM1 port of my computer for RS-232
If you need to connect it to a micro-controller you can use MAX232 / MAX3232

you can read about the difference here: [Link: sparkfun.com]


Jump to


Protected Feature Before you can reply to a message...
You must first register for a Remote Central user account - it's fast and free! Or, if you already have an account, please login now.

Please read the following: Unsolicited commercial advertisements are absolutely not permitted on this forum. Other private buy & sell messages should be posted to our Marketplace. For information on how to advertise your service or product click here. Remote Central reserves the right to remove or modify any post that is deemed inappropriate.

Hosting Services by ipHouse