Your Universal Remote Control Center
RemoteCentral.com
RS-232 & IP Control Forum - View Post
Previous section Next section Previous page Next page Up level
Up level
The following page was printed from RemoteCentral.com:

Login:
Pass:
 
 

Page 2 of 3
Topic:
Sirius SCH2P RS232 Control Protocol?
This thread has 40 replies. Displaying posts 16 through 30.
Post 16 made on Monday September 12, 2011 at 11:46
sank
Lurking Member
Joined:
Posts:
September 2011
2
received; thanks!
Post 17 made on Saturday September 17, 2011 at 14:53
Observer
Lurking Member
Joined:
Posts:
September 2011
1
Duct Tape, can I also get a copy of the protocol?
Post 18 made on Monday November 21, 2011 at 18:59
loscabosav
Lurking Member
Joined:
Posts:
November 2011
4
Hello, I saw a post that you have a RS232 File for the Sirius SCH2P. i am using for a MX-880 and MSC-400. Thanks for your help!
Post 19 made on Thursday December 29, 2011 at 08:42
Chevyboy
Lurking Member
Joined:
Posts:
December 2011
1
Could I also get the SCH2P info? Thanks.
Post 20 made on Friday December 30, 2011 at 06:53
tarakona
Lurking Member
Joined:
Posts:
December 2011
1
Can I also get a copy of the protocol?
Thanks!
Post 21 made on Tuesday March 6, 2012 at 07:37
advancedav
Lurking Member
Joined:
Posts:
March 2012
1
Would you please e-mail the RS-232 command set for the Sirius SCH2P Tuner if you have it as I have had no response from Sirius.

Thank you
Doug
doug l
Post 22 made on Thursday March 15, 2012 at 19:33
The Gooch
Long Time Member
Joined:
Posts:
March 2005
12
Could you please email the protocol to me as well? Really appreciate it! Thx!
Scott
Post 23 made on Thursday April 19, 2012 at 15:29
sgettle
Lurking Member
Joined:
Posts:
June 2008
4
Is there a "Previous" command in the protocol? I'm using RTI's two way driver, and this command isn't in the driver.

Side note: I'm having a problem with the SCH2P in that every 10 minutes or so, I lose channel up and channel down control. However, direct channel access still works, and once I select a channel, up and down work again. I want to solve this problem by jumping to a specific channel and then back to the previous one, but there isn't a command to go back to the previous channel. Unless there is.
Post 24 made on Sunday April 22, 2012 at 14:07
rjw
Lurking Member
Joined:
Posts:
April 2012
1
Also looking for the protocol, please send!

I'd like to make a module for my home webserver. Then control it from ipad, iphone etc...
Post 25 made on Sunday September 2, 2012 at 11:39
stuff
Long Time Member
Joined:
Posts:
July 2012
19
I could use the link as well, thanks
Post 26 made on Monday September 3, 2012 at 16:50
Barry Gordon
Founding Member
Joined:
Posts:
August 2001
2,108
I implemented a full version of the control system for that Sirius box. I drive the control loop off of a PC via a FTDI cable which I terminated in the required DIN Connector. I added one line from the AVP that is a trigger that stays high when the AVP is on and the Sirius is selected as the source. That unit has a trigger line to power it on and off.

Works like a charm with no problem. Control is from wall mounted iPads using software I designed in Command Fusion to talk to the PC that controls the Theater/Audio room.

I have posted the archive on my web site (the-gordons.net) bottom of the main page follow the link to downloads, then in the first section you should find it.

Last edited by Barry Gordon on September 3, 2012 17:40.
Post 27 made on Wednesday September 19, 2012 at 18:20
AdQue
Lurking Member
Joined:
Posts:
September 2012
1
Glad to have found you.  We are lookin for the codes as well.  Can you send these to us?

Thanks,
Terry
Terry
Post 28 made on Wednesday September 19, 2012 at 23:19
Barry Gordon
Founding Member
Joined:
Posts:
August 2001
2,108
If you are talking to me, then pull them off my web site. Everything I have is there
Post 29 made on Tuesday October 9, 2012 at 17:55
aro
Long Time Member
Joined:
Posts:
July 2008
17
I have a issue with this tuner. sch2p

I had this working for full year. Manager from restaurant called us that Sirius is not working.
I went there and tuner showing no signal.
when I switched dip switch to pos 3 I'm getting signal and sound.
I assumed something happens to tuner.
I got new one today. same thing when on pos 3 its fine when on dip 1 no signal and no sound.

any ideas how to fix it. ??
Post 30 made on Wednesday October 10, 2012 at 08:38
Barry Gordon
Founding Member
Joined:
Posts:
August 2001
2,108
by dip switch I assume you mean the control type selection switch on the rear of the unit. In position 3 it sets the unit to respond to IR. In position 1 it sets the unit to respond to RS232.

Your problem could be anyone of a number of things. I would suspect blown RS232 receiver/driver chips due to some electrical issue. I'm assuming that the code has not changed and there are no disconnected cables, and whatever you are using to convert the Pronto output to RS232 ihas been checked and is functioning.
Page 2 of 3


Jump to


Protected Feature Before you can reply to a message...
You must first register for a Remote Central user account - it's fast and free! Or, if you already have an account, please login now.

Please read the following: Unsolicited commercial advertisements are absolutely not permitted on this forum. Other private buy & sell messages should be posted to our Marketplace. For information on how to advertise your service or product click here. Remote Central reserves the right to remove or modify any post that is deemed inappropriate.

Hosting Services by ipHouse