Your Universal Remote Control Center
RemoteCentral.com
RS-232 & IP Control Forum - View Post
Previous section Next section Up level
Up level
The following page was printed from RemoteCentral.com:

Login:
Pass:
 
 

Topic:
Sharp RS232 "ON" Command doesn't work @ LC26P55E
This thread has 13 replies. Displaying all posts.
Post 1 made on Thursday March 12, 2009 at 05:46
nielsy
Lurking Member
Joined:
Posts:
January 2009
4
Dear all,

I have a Sharp LCD ( LC26P55E ) with RS232 all commando's works great.
But only the 'Power On' not...

I already try this :
Send command "RSPW0001" from PC. (Enables TV to use ON command)
Send command "POWR0000". => TV turn off. 4. Send command "POWR0001". =>
TV turn on. And if send "RSPW0000". => Shift to "Default" can not turn on TV with RS232

But without a good result... Who could help me?
Thanx

ps. with all other rs232 commands works fine...
Post 2 made on Thursday March 12, 2009 at 17:02
Oz AVI
Senior Member
Joined:
Posts:
November 2004
1,115
This is some infomation 39 Cent Stamp sent me that helped when I was having the same issues with Sharp RS232.

Menu/setup/standby mode/Mode 1 Should be enabled

Mode 2 offers power saving but causes the display not
to come on via rs-232 power on command.

I didnt send any strings to it to change modes.


This should fix it!

Iain
OP | Post 3 made on Tuesday March 17, 2009 at 14:24
nielsy
Lurking Member
Joined:
Posts:
January 2009
4
Iain,

Thanx for your reply, I tried but I couldn't found it in the menu...

Maybe a secret menu??

or maybe a other solution??? Anyone have a tip?
Post 4 made on Tuesday March 17, 2009 at 18:07
39 Cent Stamp
Elite Member
Joined:
Posts:
May 2007
16,002
The problem i was having was that the TV has energy saving settings that, when set to a specific mode, cause the TV to go into 'deep sleep' and RS232 cant wake it up.

Do you have the manual for the TV? If not try downloading it with this link [Link: tradenet.sharp.co.uk]

It appears, from the manual, that your menu may be slightly different. Hopefully you can navigate the confusion and find a menu with power settings that will allow you to solve the deep sleep problem.

Check page 14 for Power Management information. According to the manual it looks like the factory default may be to have the power saving settings OFF. And its quite possible that the manual is talking about something completely different and more confusing :). Poke around and see what you can come up with. Good Luck.

Adding... I didnt have to go into a secret service menu but anything is possible and your model may require you to do it. Im not aware of the steps to get into Sharps secret service menu (if it exists) though.
Post 5 made on Tuesday April 7, 2009 at 01:26
ianrob
Long Time Member
Joined:
Posts:
June 2008
24
We had this problem too. What you've got to do is turn the unit on and send the following hex string, ONCE ONLY, to turn off the Energy Saver mode.

52 53 50 57 30 30 30 31 0D

Worked for us. Unfortunately, if you turn it off with the IR remote after this, it forgets and puts energy saver mode back on after about 30 seconds.

So lose the IR remote!

Hope this helps.
OP | Post 6 made on Tuesday April 7, 2009 at 05:20
nielsy
Lurking Member
Joined:
Posts:
January 2009
4
Thanx, I will try it tonight!

Thanx for your reply!
I will let you know if it also worked for me...
Post 7 made on Thursday April 9, 2009 at 14:53
Tdurrant20
Long Time Member
Joined:
Posts:
March 2009
21
your enable command is wrong

it should be this
RSPW1 CR

there are three spaces between the 1 and the carriage return

which 232 controller are you using?
that will turn it off permanetly
Post 8 made on Thursday April 9, 2009 at 14:55
Tdurrant20
Long Time Member
Joined:
Posts:
March 2009
21
sorry i ment that will turn off the energy saving mode permanently

btw, from my documentatation your power commands are wrong

they should be POWR1 CR for on
POWR0 CR for on

noticeagain the 3 spaces
OP | Post 9 made on Monday April 20, 2009 at 03:57
nielsy
Lurking Member
Joined:
Posts:
January 2009
4
I use a AMX controller for rs232.

Your right about : POWR0 ,cr ect. In my program is that right.
Everything works fine exept the ON command.

I give it a try to using RSPW1 CR and will see if then the ON command will works... Else I think it must be done by IR... but I hope this will work!

Thanx! I let you know...
Post 10 made on Monday June 8, 2009 at 19:38
pilasz
Long Time Member
Joined:
Posts:
September 2007
121
Try RSPW1___CR - underscore equals three space characters.
In URC speak that would be RSPW1\x20\x20\x20.
Actually RSPW1 command is power save disable.
e-Age Services
Art of politics - make them have it your way..
Post 11 made on Thursday October 1, 2009 at 21:29
Tarzan2
Long Time Member
Joined:
Posts:
October 2004
38
RSPW1 \r
This fixed the problem for me on a LC65E77UM.

Thanks.
Post 12 made on Wednesday March 22, 2017 at 22:28
lmaldo41
New Member
Joined:
Posts:
March 2017
1
FYI, I been working on the newest Sharp 80" LC80LE661U opening up the RS232 port on the LED TV. There are two step to make the the RS232 active. First, turn on the TV with the remote control, go to the "menu" hit the menu button, tab over to Intial Setup tab. scroll down to the Quick Start Mode and turn it "ON". this function over rides the energy saving mode. The second step is to send the comand 'RSPW1 ',$0D or 13. I was using SP control NRC to control the the sharp 80" LED TV. I hope this helps
Post 13 made on Thursday April 20, 2017 at 15:26
rbenavi409
New Member
Joined:
Posts:
April 2017
1
Imaldo41
Thanks for this info.....Changing the Quick Start Mode to 'ON' fixed the remote RS-232 Power ON command. I was stuck on that issue for a little bit, but your suggestion fixed that problem. I didnt have to use the 'RSPW1' command......but I am using HEX for control.
504F5752312020200D = Power ON
504F5752302020200D = Power OFF
Post 14 made on Friday May 19, 2017 at 21:52
htmlcolor
New Member
Joined:
Posts:
May 2017
2
Hi. I am also a new member of the forum. I am looking forward to exchange and learn more. Looking forward to sharing more with the same people!
html color picker


Jump to


Protected Feature Before you can reply to a message...
You must first register for a Remote Central user account - it's fast and free! Or, if you already have an account, please login now.

Please read the following: Unsolicited commercial advertisements are absolutely not permitted on this forum. Other private buy & sell messages should be posted to our Marketplace. For information on how to advertise your service or product click here. Remote Central reserves the right to remove or modify any post that is deemed inappropriate.

Hosting Services by ipHouse