Your Universal Remote Control Center
RTI Control Systems Forum - View Post
Previous section Next section Up level
Up level
The following page was printed from


T2x not connecting via USB
This thread has 6 replies. Displaying all posts.
Post 1 made on Tuesday May 29, 2018 at 19:50
Long Time Member
August 2013
one of my T2x units no longer is recognized via the usb port connection, all other work ok.
I have removed battery and done several resets but nothing works.
I have not been able to get the WiFi connection working so I am at a loss at what to do.
The T2x works fine otherwise, cant update program till this is fixed, any help would be appreciared
Post 2 made on Thursday May 31, 2018 at 19:10
Lurking Member
August 2012
Do you have another cradle you can put the controller on to see if it's the charging base that's not working correctly? If not, you may want to call RTI and see if you can do an RA for the unit.
Post 3 made on Thursday May 31, 2018 at 20:36
Long Time Member
November 2004
I had this issue and needed the most current version of ID to get it to recognize remote
"Was it for this my life I sought? Maybe so, Maybe not...
Post 4 made on Friday June 1, 2018 at 08:03
Long Time Member
March 2007
Try a different USB port on your laptop

Reboot laptop, without remote attached

Reboot with remote attached
Post 5 made on Friday June 1, 2018 at 13:22
RTI Vincent
Junior Member
September 2017

We are finding that a lot of these newer generation laptops are underpowering these USB ports. Plugging into power usually alleviates these problems.

The other issue is that it has the driver installed already on a designated COM port from a previous RTI device being connected, meaning a reboot will usually fix the problem or ultimately updating the USB controller hardware drivers from the PC manufacturers website.

Please contact our tech support department if these issues are still failing as we would like to log them in addition to the troubleshooting.

Vincent Bova
RTI Dealer Experience Manager
Remote Technologies Inc.
OP | Post 6 made on Friday September 7, 2018 at 19:48
Long Time Member
August 2013
yep tried all that, still not working, the unit is not charging as well I have found.
Have logged a warranty job with RTI, i think the device is broken
thanks for the suggestions
Post 7 made on Wednesday October 2, 2019 at 17:34
Select Member
August 2004
I am still having issues with about 25% of the T2x units. T2i does not seem to have the issue that I can recall. Sometimes I get lucky and it will connect with just enough time to load before it drops off.

I have found that a full charge on the remote helps but is not guaranteed to work.

I have tried all manner of PC and remote reboots, four different USB ports, through the base and with the direct programming cable (two of them).

This was not always the case and seems to be an uptick in the problem.

Today a simple pull of the battery to disconnect power did the trick. Guessing it is a capacitance issue of some sort.

Jump to

Protected Feature Before you can reply to a message...
You must first register for a Remote Central user account - it's fast and free! Or, if you already have an account, please login now.

Please read the following: Unsolicited commercial advertisements are absolutely not permitted on this forum. Other private buy & sell messages should be posted to our Marketplace. For information on how to advertise your service or product click here. Remote Central reserves the right to remove or modify any post that is deemed inappropriate.

Hosting Services by ipHouse