Your Universal Remote Control Center
RemoteCentral.com
Audio, Receivers & Speakers Forum - View Post
Previous section Next section Previous page Next page Up level
Up level
The following page was printed from RemoteCentral.com:

Login:
Pass:
 
 

Page 2 of 2
Topic:
Using the Serial Data input of my Bose Lifestyle 50 system
This thread has 20 replies. Displaying posts 16 through 21.
Post 16 made on Friday March 22, 2013 at 04:59
aktur
Lurking Member
Joined:
Posts:
March 2013
1
Wow, almost 10 years old thread comes as first in Google when searching on 'Bose serialdata'! Anyway, I'm an integrator of OpenRemote and currently I'm adding Bose protocol to OpenRemote. Results are promising and anybody interested is invited to test it (when it will be released of course). You can find more about OpenRemote project on http://www.openremote.org
For logging my experience with the protocol integration I use the blog [Link: mqlservice.net]
Please note that OpenRemote is free and open source project.
Kind Regards,
Michal Rutka
[Link: mqlservice.net]
Post 17 made on Tuesday February 24, 2015 at 19:56
Dave_247
Junior Member
Joined:
Posts:
February 2015
1
Hi. I'm joining the thread that won't die :)

I have a Lifestyle 50 system, and have been trying to control it via Serial Data, using the info on this thread. I have a TTL to 3.5 mm cable, as described in previous posts. I'm sure the cable is ok, as I've checked it with the TTL port of Raspberry Pi.

I have tried controlling the LS 50 using the codes posted by rjbradlow nearly 5 years ago - but these are LS 20 codes - they don't seem to work. However, I can get signs of life from the serial port with my TTL cable - but interestingly it only works at baud 4800 (even though other posters have said 1200). It doesn't always seem to want to talk to me, but I have also seen output on the port (again, some posts indicate there is no transmit from the unit).

After some fiddling, I've seen the word Reset! appear, and a command prompt. Mostly I get Unknown Command! if I type something. But I have lucked on something more interesting. Typing "BO" (I guess short for BOSE) gives ...

ETAP Interface V1.5 [abdefrmnt] (C) 1999 Bose Corporation.
Device = 0001


DE gives some memory print out (probably DEBUG?). "MO0" and "MO1" seems to sett "Messages off" and "Messages on" respectively (whatever that means). Also, "MM " seems to be the header for other commands, since it waits for more input after that.

As you can see, I'm frustratingly close, but not there yet. The codes posted are LS 20 codes. Does anyone know what the codes are for LS 50? Are they different? Where might I get hold of them?

One further point - as I said, the connection to the Bose unit seems not too reliable. My TTL cable is 3.3V. I'm pretty sure from my web searching that the unit is a 5V level RS-422 - so perhaps that's why my connection is intermittent.

My ultimate goal is to use my phone to control the Bose Lifestyle 50, by sending data by wifi from my phone to a Raspberry Pi, which would then relay commands to the LS 50 via the serial port. No idea if I'll ever get there though! :)

Last edited by Dave_247 on February 26, 2015 10:19.
Dave_247
Post 18 made on Monday April 4, 2016 at 05:41
supplyimaging
Junior Member
Joined:
Posts:
April 2016
1
[Link: myuremote.com]
and
[Link: lintronic.dk]

are two possible solutions which I have NOT tried.

Should be possible from Raspberry pi though......
Post 19 made on Monday May 23, 2016 at 06:32
lakrdijash
Junior Member
Joined:
Posts:
May 2016
1
Wow,

When this thread started I was 14 years old and thought I would be a rock star.
Now, I had to join this, as I am running into a lot of Lifestyles with AV integration on Yacht systems. For some reason, Yacht manufacturers adore Bose.

Has there been any updates from Bose in terms of control via third party?
Post 20 made on Monday May 30, 2016 at 01:55
Ernie Gilman
Yes, That Ernie!
Joined:
Posts:
December 2001
27,170
Start a new thread about this in the Custom Installers Forum because the guys who play there rarely play here. Get a whole new audience.

And look at the negative comments you've found in this thread about bringing up old threads. really, start a NEW thread.
A good answer is easier with a clear question giving the make and model of everything.
"The biggest problem in communication is the illusion that it has taken place." -- G. “Bernie” Shaw
Post 21 made on Friday July 22, 2016 at 18:34
GammaRayBurst
Junior Member
Joined:
Posts:
July 2016
1
I joined just to post to this ancient thread. I found it while searching for information on the serial data port on my Bose Lifestyle 35's AV28 Media Center. One of the earliest posts mentioned that it was possibly used internally by Bose for programming, and that was the conclusion I had come to.

I had wondered how one would go about replacing the DVD-ROM with a different model. Mine had a problem that seems to be very common in these: a slipped gear was preventing the eject from working properly. It's possible to repair the gear or replace the drive with the same model...

BUT, I got to thinking about how one would replace the DVD-ROM with another IDE model from the same manufacturer, or even one from a completely different manufacturer. The driver is built into the firmware most likely. And firmware updates come on (bootable, unknown OS) CD-ROM. Assuming you could figure out the format of the CD for the firmware update, how would you replace the driver for the DVD-ROM while you're using the drive? (This is a "chicken or the egg" type of question.)

My thought was that you couldn't do this via a CD-ROM update, and that you'd have to be able to bypass the DVD-ROM entirely and write to the PROM chips in some other way. That's when I said, "Aha! The serial data port!"

So the question I have would be how to use the serial data port to do firmware updates. Specifically, how is the data stored in the PROM chips? (What is the OS, file system, etc?) And how would you replace the driver for the DVD-ROM so you could replace the drive with a different model? (You'd have to be 100 percent certain about what you're doing, because this is definitely the recipe for turning your Lifestyle into a brick, if you aren't careful.)

There are people selling this drive for upwards of $400, because they know what they have. If you could find a way to update the driver via the serial data port, you'd have a wider choice of replacement drive options.
Page 2 of 2


Jump to


Protected Feature Before you can reply to a message...
You must first register for a Remote Central user account - it's fast and free! Or, if you already have an account, please login now.

Please read the following: Unsolicited commercial advertisements are absolutely not permitted on this forum. Other private buy & sell messages should be posted to our Marketplace. For information on how to advertise your service or product click here. Remote Central reserves the right to remove or modify any post that is deemed inappropriate.

Hosting Services by ipHouse