Your Universal Remote Control Center
Philips Pronto NG Family Forum - View Post
Previous section Next section Up level
Up level
The following page was printed from


Pronto 7500 hard buttons not working
This thread has 1 response. Displaying all posts.
Post 1 made on Saturday October 26, 2013 at 14:55
Long Time Member
November 2007
I have a Pronto 7500 that all of my hard buttons have stopped working/responding. The screen works - but no hard buttons. I've tried resetting... i've tried reloading the program... I have a second (luckily) backup 7500 that is working... has anybody run into this before, and any suggestions on what I could possibly do to get it fixed?!

Dahr Fry
Pronto TSU7500 / Pioneer FHD1 / Onkyo 805 / Sony S300 / Sony PS3
Post 2 made on Saturday October 26, 2013 at 15:44
Lyndel McGee
RC Moderator
August 2001
Reload the firmware, not just your config. If that does not fix it then see
Lyndel McGee
Philips Pronto Addict/Beta Tester

Jump to

Protected Feature Before you can reply to a message...
You must first register for a Remote Central user account - it's fast and free! Or, if you already have an account, please login now.

Please read the following: Unsolicited commercial advertisements are absolutely not permitted on this forum. Other private buy & sell messages should be posted to our Marketplace. For information on how to advertise your service or product click here. Remote Central reserves the right to remove or modify any post that is deemed inappropriate.

Hosting Services by ipHouse