Your Universal Remote Control Center
RemoteCentral.com
Philips Pronto NG Family Forum - View Post
Previous section Next section Previous page Next page Up level
Up level
The following page was printed from RemoteCentral.com:

Login:
Pass:
 
 

Page 1 of 2
Topic:
TSU7500 White Screen Problem
This thread has 27 replies. Displaying posts 1 through 15.
Post 1 made on Thursday January 11, 2007 at 23:09
ANILE8
Long Time Member
Joined:
Posts:
April 2006
11
Ok I have searched and found this to be a very rare problem or have others out there suffered the same fate?

I have a TSU7500 which the screen started to flicker white and then off really quickly when I picked it up then soon after the screen went to constant white color and would not respond to resetting or battery removal procedures.

Is this a common phenomena or am I just unlucky?

The remote control is only a week old!

Last edited by ANILE8 on January 12, 2007 00:15.
Post 2 made on Friday January 12, 2007 at 07:55
Springs
Super Member
Joined:
Posts:
May 2002
3,238
Replace it. Its screwed. Been there.
Post 3 made on Sunday January 14, 2007 at 05:30
Yore
Founding Member
Joined:
Posts:
August 2001
16
Interesting...I have a problem with TSU 990 constantly rebooting if it is handled a little longer. The screen either has a black line with icons seens like watermarks or then if flashes the light on and off about 15 seconds and reboots. I've called Philips about 1,5 half ago but have got no reply yet.
OP | Post 4 made on Sunday January 14, 2007 at 17:21
ANILE8
Long Time Member
Joined:
Posts:
April 2006
11
On January 12, 2007 at 07:55, Springs said...
Replace it. Its screwed. Been there.

Yeah your right.

I have sent my unit back to Philips. I think it is stuffed.

Thanks for the advice.
Post 5 made on Saturday February 10, 2007 at 23:00
bdmfkr
Lurking Member
Joined:
Posts:
February 2007
4
this problem just happened to mine tonight, did you just contact Philips directely to send it back?
Post 6 made on Sunday February 11, 2007 at 09:00
mtgriff
Long Time Member
Joined:
Posts:
July 2002
289
My son and daughter were fighting over my daughter's Nintendo DS. It ended up on the floor. After the fall it had white lines across the screen. It's screwed.

It sounds like something simular might be what happend to your remote control screen.
Harmony One
OP | Post 7 made on Tuesday February 13, 2007 at 06:40
ANILE8
Long Time Member
Joined:
Posts:
April 2006
11
On February 10, 2007 at 23:00, bdmfkr said...
this problem just happened to mine tonight, did you just
contact Philips directely to send it back?

I contacted Philips and they were great about things. They gave me a return number and I sent it to them. Two weeks later they sent me a new one as it was only 1 week old.
OP | Post 8 made on Tuesday February 13, 2007 at 06:47
ANILE8
Long Time Member
Joined:
Posts:
April 2006
11
On February 11, 2007 at 09:00, mtgriff said...
My son and daughter were fighting over my daughter's Nintendo
DS. It ended up on the floor. After the fall it had white
lines across the screen. It's screwed.

It sounds like something simular might be what happend
to your remote control screen.

The remote that had this problem with was a customer of mine that I sold it to and only had it for a week. They said they didn't drop it, but who knows.

I would imagine that if a remote control cannot be built to take a drop now and then without a serious malfunction it is not being built to high enough real world use standards. I do not expect to be able to abuse the unit and it keep working but a small drop of under 3' onto carpet shouldn't be enough to destroy an expensive unit like the TSU7500 one would hope.
Post 9 made on Tuesday February 13, 2007 at 08:18
mtgriff
Long Time Member
Joined:
Posts:
July 2002
289
One would think that a kid's toy could take a drop too.
Harmony One
Post 10 made on Saturday February 17, 2007 at 15:45
bdmfkr
Lurking Member
Joined:
Posts:
February 2007
4
On February 13, 2007 at 06:40, ANILE8 said...
I contacted Philips and they were great about things.
They gave me a return number and I sent it to them. Two
weeks later they sent me a new one as it was only 1 week
old.

thanks, i just shipped mine off to Philips, they said i should have a new one in 2-3 weeks.
Post 11 made on Friday June 29, 2007 at 15:53
swiesen
Long Time Member
Joined:
Posts:
August 2006
12
EXACT same problem. Mine is in for warranty exchange right now. As mine is about 8 months old, only a warranty repair/replacement was possible. Only problem is that Philips doesn't handle their own warranties so I had to outsource it to another repair place that is taking forever! I mailed it in a 6 weeks ago and no word yet.

I wonder with all this talk about the TSU-7500 being discontinued, if that would have an effect on warranty exchanges?
Post 12 made on Friday June 29, 2007 at 23:19
Lyndel McGee
RC Moderator
Joined:
Posts:
August 2001
11,922
Should have no affect. There's a backstock of 7500s so it's probably just a slow repair shop. Have you given them a call?
Lyndel McGee
Philips Pronto Addict/Beta Tester
Post 13 made on Tuesday October 23, 2007 at 08:27
mmiele
Lurking Member
Joined:
Posts:
October 2007
2
I recently purchased a used TSU7500 and it started having problems and now pretty much dead. The screen was fuzzy yesterday and within a day it went all white. I tried resetting it, then downloading new firmware -- same issue. It sounds familar to the problems here where a repair is needed. I did not purchase this from Phillips (eBay actually) so does anyone know if there are repair facilities that is dependable? thanks
Post 14 made on Tuesday October 23, 2007 at 21:16
Lyndel McGee
RC Moderator
Joined:
Posts:
August 2001
11,922
[Link: pronto.philips.com]

This is the Pronto Support line. From there, they can tell you how to swap your unit/send in for repair. If not under warranty, it may cost you a bit to get a screen.

You might want to search for +replace +7000 +screen (for last 4 years) as there was once a link in one of these posts where you could order a screen. Screens may no longer be available but glasstops for screen may still be available. In this case, your only option will be Philips.
Lyndel McGee
Philips Pronto Addict/Beta Tester
Post 15 made on Wednesday November 21, 2007 at 02:17
old_skool
Lurking Member
Joined:
Posts:
November 2007
3
I have this same problem with my TSU7500 (white screen). Unfortunately mine is out of warranty. Does anybody have a solution for this. Is it just the LCD or board issue?

Thanks
Page 1 of 2


Jump to


Protected Feature Before you can reply to a message...
You must first register for a Remote Central user account - it's fast and free! Or, if you already have an account, please login now.

Please read the following: Unsolicited commercial advertisements are absolutely not permitted on this forum. Other private buy & sell messages should be posted to our Marketplace. For information on how to advertise your service or product click here. Remote Central reserves the right to remove or modify any post that is deemed inappropriate.

Hosting Services by ipHouse