Your Universal Remote Control Center
Philips ProntoNEO Family Forum - View Post
Previous section Next section Up level
Up level
The following page was printed from


Pronto Neo on Windows 7 x64 machine
This thread has 5 replies. Displaying all posts.
Post 1 made on Sunday February 13, 2011 at 14:11
Lurking Member
October 2002
So I recently bought a Win7 64 bit machine, and the only thing missing is the ability to update my Pronto Neo remote (no serial port).

I bought this Sabrent USB-to-serial cable, based on reports that people had luck with the Prolific PL2303HX chipset (which I believe it uses):
[Link:] (model sbt-usc1m)

However, the packaged drivers didn't work. Nor did the drivers off Prolific's website (which, by the way, is sometimes up, sometimes down):

However, THIS driver did work:

So the device installs properly on my machine (no yellow exclamation point, and "Prolific USB-to-Serial Comm Port (COM3)" appears in the device manager), but when I try to use Neo Edit to upload the configuration, I get this message:

Error 0070: segger-module: initialization failed!

This is after "Checking connected device" appears briefly, and "Uploading" appears for a LONG time.

I've properly configured Neo Edit to use COM3, and used all the port settings detailed in the FAQ (9600 bps, 8 data bits, no parity, 1 stop bit, Xon / Xoff flow control). I also tried disabling FIFO buffers (under Advanced options) and tried using lower buffers.

Any ideas on what I can do here? Not anxious to start trying all kinds of different USB to serial adapters, but really need the ability to restore my remote if something catastrophic happens. Since I no longer have my old computer, I don't want to hard reset the device, as I'd have no way to put my configuration back on it.

Ideally, would love to know someone's exact configuration where they have this working.

Any help is appreciated!
Post 2 made on Tuesday February 15, 2011 at 07:04
Daniel Tonks
Wrangler of Remotes
October 1998
This could be a software issue (not driver/adapter issue).

If you have Windows 7 Pro or Ultimate, you could install XP mode which would probably help.
Post 3 made on Sunday March 4, 2012 at 08:23
Long Time Member
July 2002

I don't know if you solved the problem; but i just had the same issue.
The solution is to run NeoEdit as an Administrator (right click NeoEdit icon and choose 'run as an administrator'

Post 4 made on Sunday December 9, 2012 at 09:10
Lurking Member
March 2005
I'm running on a Windows 8 PC with a USB to serial cable com also. Had the same upload problem. Tried everything with no luck. Then when installing neohacker, I had to install Java jre. That solved my problem. Working great now.
Post 5 made on Thursday August 10, 2017 at 18:37
Lurking Member
March 2003
On February 13, 2011 at 14:11, jbroses said...
Error 0070: segger-module: initialization failed!

I feel like I am raising the dead by re-opening this thread. But, I haven't made any changes to my Pronto Neo in over 10 years. I have upgraded/replaced several components in my home theater system, and I now want to update my remote.

I am getting the the same Error 0070 that jbroses reported.

I am using the same USB-to-Serial interface that jbroses was using. I am running Win7 64 bit Pro. The serial port comes up as COM3. I use this same interface to program a Uniden scanner so I know it works.

Based on posts on RemoteCentral and elsewhere, I have tried all of the following:
- Uninstall NeoEdit, clean registry of all remaining Philips entries, reinstall NeoEdit
- Run NeoEdit as Administrator
- Run NeoEdit in WinxP SP 3 compatibility mode
- Verified COM settings are 9600, 8-bit, no parity, 1 stop bit, Xon/Xoff
- Tried reducing the number of buffers
- Tried disabling the FIFO buffers
- Updated Java to latest version
- Installed brand new batteries in the Neo
- Have done multiple resets on the Neo

In every case, when I try to upload from the Neo, I get the window saying it is Uploading, and then after several minutes I get the 0070 Segger Module:Initialization Failed error message.

I really like the large screen on this remote and hate to give it up, but if I can't communicate with it from my PC, it's of no value to me.

Does anyone have a Win7 64-bit Pro system successfully communicating with a Neo? If so I would really like to pick your brain to see what you have done to get it to work.

I would appreciate any help.
Post 6 made on Friday August 18, 2017 at 15:48
Lyndel McGee
RC Moderator
August 2001
Not sure if this will work but try setting the USB to 232 to COM1 (not COM3 - hoping for some good luck) and 9600, N, 8, 1 but with hardware flow control (not Xon/XOff - flow control change here less likely to work).
Lyndel McGee
Philips Pronto Addict/Beta Tester

Jump to

Protected Feature Before you can reply to a message...
You must first register for a Remote Central user account - it's fast and free! Or, if you already have an account, please login now.

Please read the following: Unsolicited commercial advertisements are absolutely not permitted on this forum. Other private buy & sell messages should be posted to our Marketplace. For information on how to advertise your service or product click here. Remote Central reserves the right to remove or modify any post that is deemed inappropriate.

Hosting Services by ipHouse