Your Universal Remote Control Center
RemoteCentral.com
Harmony Remote Controls Forum - View Post
Previous section Next section Up level
Up level
The following page was printed from RemoteCentral.com:

Login:
Pass:
 
 

Topic:
Harmony One Activity is Slooooow
This thread has 9 replies. Displaying all posts.
Post 1 made on Saturday July 19, 2008 at 00:07
Scott777
Founding Member
Joined:
Posts:
November 2001
12
I only have 4 devices (tv, av receiver, cable box, dvd) and when I choose the activity to watch cable or dvd, it takes anywhere from 20-30 seconds for the H1 to fire all of the commands.

What can i do to speed this up? I can pick up all of the remotes and complete this quicker than the H1.
Post 2 made on Saturday July 19, 2008 at 11:39
Sucubus
Long Time Member
Joined:
Posts:
October 2006
126
Scott777, in order to help, you will need to be more specific.
What are the devices? Make, model? What exactly takes long? Turning on the TV, going to an input?
For anyone to anwser with so few details would simply be a guess.
Post 3 made on Saturday July 19, 2008 at 13:21
akirby
Super Member
Joined:
Posts:
March 2004
4,640
Check the power-on and input delays on all devices. Reduce those if possible.
OP | Post 4 made on Saturday July 19, 2008 at 14:38
Scott777
Founding Member
Joined:
Posts:
November 2001
12
The entire sequence after hitting the activity, "Watch TV" to turn on: TV (Philips), AV Rec (Denon), Cable Box (Moto Fios) takes 30 secs.

On the previous post, it mentioned to reduce the delay times. What are "typical" times to put on each of these commands?
Post 5 made on Saturday July 19, 2008 at 18:49
rehaz1
Active Member
Joined:
Posts:
December 2005
522
There is no typical time as it is different for every device and combinations of devices. Check the power on delay for your devices time is recorded in MS 1000 = 1 sec. One way to test is to turn on each device and count the number of sec before it is ready to accept commands
Post 6 made on Saturday July 19, 2008 at 20:40
Daniel Tonks
Wrangler of Remotes
Joined:
Posts:
October 1998
28,648
You'll have to adjust the delay settings for all of your devices. Usually the default settings are conservative, but occasionally to bizarre levels. I would start off low and work your way up if commands aren't received.

[Link: remotecentral.com]

The "power on delay" setting is a pretty device specific one, and is how much time it takes after your device receives a "power on" command before it can process other commands. Some devices may be up to 10 seconds. And then others may have NO delay needed - I had a Sony RPTV that would take 10 seconds to give any picture, but it could process commands right away - like 0ms delay right away.

The "inter-key delay" can usually be shortened quite a bit. The typical default of 500ms is usually WAY too slow. Try 100ms. You may even get away with 0ms, but if you have a problem with identical commands not being received (ie channel "55" comes up just as "5") then you need to increase it.

Some devices need an "input delay", which defaults to 1 second, but most of the devices I've owned don't need any (or max out at 100-200ms). But once again, this depends on your device.

The "inter-device delay" is how much time the remote should wait between sending commands to different devices. This is only really needed if your devices tend to listen to commands that aren't meant for them and need a bit of a pause before responding to commands that ARE meant for them. I have never needed to use this, so I usually zero it out.
OP | Post 7 made on Sunday July 20, 2008 at 10:47
Scott777
Founding Member
Joined:
Posts:
November 2001
12
Thanks for this info...this actually did help increase the response times.

Another question - How do I speed up the sequence with custom buttons? For example, I have a Verizon FIOS cable box with a custom button, say Fox icon with channel 4, when pressed, i see the numbers being changed, 0-4 then enter, but this is very slow as well.
Post 8 made on Sunday July 20, 2008 at 19:06
hhatkin
Long Time Member
Joined:
Posts:
February 2008
461
Inter key delay is the one to look at there.
Do you need a sequence for it though, rather than Favorite Channels?
OP | Post 9 made on Monday July 21, 2008 at 09:53
Scott777
Founding Member
Joined:
Posts:
November 2001
12
It is set up as a Favorite Channel with icons. When this button is pressed, it takes a while for the "keystrokes" to complete. I have the interkey delay set to '0' for this device - Verizon Fios/motorola STB

Thx
Post 10 made on Monday July 21, 2008 at 16:25
jlet
Super Member
Joined:
Posts:
March 2004
2,631
Try reducing both the Inter-key and Inter-Device delays. There might be a bug where the 2 delays are swapped and/or added together.

Also check the "How do you select channels..." configuration under:
o Client S/W interface: "Device > Settings > Re-do initial setup for this device (or Advanced setup...)".
o Website interface: "Device > More Options > Redo initial setup for this device (or Advanced setup...)".
It has 4 options (2 numbers, 3 numbers, Number(s) then enter/select, Number(s) only), make sure you selected the correct one.
H659, H680, SA8300HD, TH-50PZ850, AVR-X4000


Jump to


Protected Feature Before you can reply to a message...
You must first register for a Remote Central user account - it's fast and free! Or, if you already have an account, please login now.

Please read the following: Unsolicited commercial advertisements are absolutely not permitted on this forum. Other private buy & sell messages should be posted to our Marketplace. For information on how to advertise your service or product click here. Remote Central reserves the right to remove or modify any post that is deemed inappropriate.

Hosting Services by ipHouse