Your Universal Remote Control Center
RemoteCentral.com
Custom Installers' Lounge Forum - View Post
Previous section Next section Up level
Up level
The following page was printed from RemoteCentral.com:

Login:
Pass:
 
 

Topic:
Video issues with 4K Apple TV and Sony XBR940E
This thread has 14 replies. Displaying all posts.
Post 1 made on Sunday January 28, 2018 at 21:48
PSS
Senior Member
Joined:
Posts:
December 2002
1,276
I've seen a few posts here about ATV 4K issues with various TV's.
I set it up a few weeks ago and seemed fine. I got a message from the client that they get the Apple menu but when they choose a Netflix program it goes black but the audio works.
Honestly, I don't remember how I set up the ATV and TV for video. I do remember a screen on the ATV menu an option for 4:2:2 or similar. I don't think we changed anything in the Sony menu.
My question is how best set up the ATV AND Sony TV to try to avoid any issues.
Post 2 made on Monday January 29, 2018 at 01:09
dunnersfella
Regular Member
Joined:
Posts:
October 2016
121
Did you connect the Apple TV to HDMI 2 or 3?
Did you switch those HDMI inputs to 'Extended mode'?
4:2:2 / 10bit should be fine if you do that.
My signature? It matches the one on the back of my credit card.
Post 3 made on Monday January 29, 2018 at 06:43
designed
Long Time Member
Joined:
Posts:
November 2012
284
I'm having this issue as well with the same TV as well as with a Samsung and an LG. The Samsung and LG OLED both have hdmi switches that are 10.2gb. The Apple tv works fine on 4k/60 but will not pass video through 4k Netflix content nor will Prime load.

The Sony is on hdmi 2 and the enhanced setting on the input was set initially.
OP | Post 4 made on Monday January 29, 2018 at 10:17
PSS
Senior Member
Joined:
Posts:
December 2002
1,276
On January 29, 2018 at 01:09, dunnersfella said...
Did you connect the Apple TV to HDMI 2 or 3?
Did you switch those HDMI inputs to 'Extended mode'?
4:2:2 / 10bit should be fine if you do that.

I don't know which HDMI input it's on. What is the correct one for this situation?
Is the "extend mode" an option in the Sony or ATV? And what should it be on? not extended or extended? (do you mean extended or enhanced per post above?)
TIA!
Post 5 made on Monday January 29, 2018 at 11:04
rlustig
Advanced Member
Joined:
Posts:
June 2004
902
just had the exact thing happen Friday. Apple TV update and reboot. netflix started working again.
Post 6 made on Tuesday January 30, 2018 at 23:30
SOUND.SD
Loyal Member
Joined:
Posts:
April 2006
5,512
This is an industry wide issue. Mostly reported on Sony Tv's but always with Apple TV 4K. Posts on Mac forums, reddit, everywhere. In this instance, it's not your cables, is simply an issue with Apple TV. Of course the job I've been troubleshooting it for months is a cord cutter and his only source of TV. I've eliminated the matrix switch and went loan to each Apple TV and the problem still exists. This has made me look like a fool on this job and there is nothing I can do about it. A reboot will fix until a period of inactivity then it happens again. Im done with Apple.
Bulldog AV - San Diego, CA
www.bulldog-av.com
[Link: facebook.com]
Post 7 made on Wednesday January 31, 2018 at 00:40
designed
Long Time Member
Joined:
Posts:
November 2012
284
It definitely is happening on multiple Sony's with the Apple TV plugged into hdmi 2 locally. The 4k enhanced input setting is enabled. I can also confirm the issue happens when the Apple TV is going through a 10.2gb switch. There doesn't seem like there is anything we can do at the moment to resolve this.
Post 8 made on Wednesday January 31, 2018 at 02:07
Audiophiliac
Super Member
Joined:
Posts:
August 2006
3,124
Set it to 1080p.
"When I eat, it is the food that is scared." - Ron Swanson
Post 9 made on Wednesday January 31, 2018 at 07:43
vwpower44
Super Member
Joined:
Posts:
August 2004
3,603
I have had all kinds of issues with he AppleTV. Set it to 4k 60 SDR and be done. If they want 4k HDR sell them a Roku and have them use Amazon. 4k HDR through the appleTV is too wonky, and it works and sometimes it does not.
Stay Hungry, Stay Foolish...
Post 10 made on Wednesday January 31, 2018 at 08:09
designed
Long Time Member
Joined:
Posts:
November 2012
284
On January 31, 2018 at 02:07, Audiophiliac said...
Set it to 1080p.

I tried this. Also my other issue is using 4k sdr through a 10.2gb/s switch. Menus work fine you'd expect the content to be fine as well. It used to be before Apple updated to the match content format and yes I have tried both on and off for that setting.
Post 11 made on Wednesday January 31, 2018 at 11:35
Impaqt
RC Moderator
Joined:
Posts:
October 2002
5,703
On January 31, 2018 at 02:07, Audiophiliac said...
Set it to 1080p.

the AppleTV 4K has an incredibly annoying habit of going back to 4K if it reboots.

And Obviously, Netflix wont play in 4K when its set to 1080p.
I'm no engineer, but I did stay at a Motel 6 last night!
Post 12 made on Wednesday January 31, 2018 at 12:33
SOUND.SD
Loyal Member
Joined:
Posts:
April 2006
5,512
On January 31, 2018 at 02:07, Audiophiliac said...
Set it to 1080p.

I'm guessing you haven't played with this Apple TV much?
Bulldog AV - San Diego, CA
www.bulldog-av.com
[Link: facebook.com]
OP | Post 13 made on Monday March 12, 2018 at 15:56
PSS
Senior Member
Joined:
Posts:
December 2002
1,276
Still having issues with this setup......
Client says sometimes they pick a show and they get no sound. So she has to go to settings in the atv and restart. This fixes it. She said almost every time she has to do this.
Today, only the apple logo with a grey screen. I power cycled it and everything works. I updated the atv firmware (11.2.6) and now in the middle of updating the Sony 940.
I'm leaving here today with the following settings:
Atv I plugged into input 2 of the Sony 940
HDMI 2 is set for enhanced in the Sony menu

Atv format is set to 4KSDR 60hz
HDMI output is YCbCr
Chroma is 4:2:0
Set to match content (range and frame rate)

From all your experience are these the best settings to have at this point? The one I question is the match content. I'm afraid it may switch a video setting and cause issues. It's not like it's already a pita, but trying to fix this damn thing!!
Post 14 made on Monday March 12, 2018 at 16:53
Impaqt
RC Moderator
Joined:
Posts:
October 2002
5,703
Are we using a receiver in the loop here? If not, why not just use the Netflix app in the TV?

the Grey screen with an apple logo makes it sound likes it is indeed a bad appleTV.
I'm no engineer, but I did stay at a Motel 6 last night!
Post 15 made on Monday March 12, 2018 at 18:03
Brad Humphrey
Select Member
Joined:
Posts:
February 2004
1,575
On March 12, 2018 at 16:53, Impaqt said...
.... why not just use the Netflix app in the TV?

LOL, you really want to piss the customer off don't you.

Being serious; it maybe that the customer would have no problem using the app in the TV. But for a lot of people, it is to confusing - no matter how straight forward it seems to us.
With the Sony, you often have to search around to find the freaking app you want to use. It will sometimes jump around on the horizontal scroll bar of apps. And of course the customer has to know which scroll bar to go to as well - again obvious to us but maybe not to someone who doesn't see the app they are looking for immediately. The Sony TV app menu is one of the worse.
At least with Netflix, there is a dedicated command to get to it. Other apps, good luck.
And I'm guessing they paid almost 2x the cost for the Apple TV 4K over the Roku, because they want to use their iTunes and other Apple centric stuff. Not going to happen on the Sony TV apps either.

[edit]: If all the firmware updates do not fix the problem. Might be time to short the ATV out and claim warranty for a new one. Hopefully it is not an issue with the TV... yikes!!!!


Jump to


Protected Feature Before you can reply to a message...
You must first register for a Remote Central user account - it's fast and free! Or, if you already have an account, please login now.

Please read the following: Unsolicited commercial advertisements are absolutely not permitted on this forum. Other private buy & sell messages should be posted to our Marketplace. For information on how to advertise your service or product click here. Remote Central reserves the right to remove or modify any post that is deemed inappropriate.

Hosting Services by ipHouse