Your Universal Remote Control Center
RemoteCentral.com
Philips Pronto Professional Forum - View Post
Previous section Next section Up level
Up level
The following page was printed from RemoteCentral.com:

Login:
Pass:
 
 

Topic:
TSU9600 stuck on Philips screen
This thread has 1 response. Displaying all posts.
Post 1 made on Sunday July 25, 2021 at 15:11
rlpronto
New Member
Joined:
Posts:
July 2021
1
Have a TSU9600 been in storage for a while. Pulled it out to setup to sell along with the extender. Turning it on it is stuck on the blue PHILIPS screen. Tried various key combos (home/channel up/menu, brightness/home/menu) nothing loads it off the screen. I installed PronoEdit 3.0.23.0 but it isn't seeing the device, guess because it never loads. Any ideas how to get it to recover?
Thank you!
Post 2 made on Monday July 26, 2021 at 19:04
Lyndel McGee
RC Moderator
Joined:
Posts:
August 2001
12,729
Search for 'complete firmware reload' or simply look at the posts currently on the main screen.

[Link: remotecentral.com]

Provided you still have a copy of .xcf file on computer somewhere, you should be able to recover with no issues.
Lyndel McGee
Philips Pronto Addict/Beta Tester

Jump to


Protected Feature Before you can reply to a message...
You must first register for a Remote Central user account - it's fast and free! Or, if you already have an account, please login now.

Please read the following: Unsolicited commercial advertisements are absolutely not permitted on this forum. Other private buy & sell messages should be posted to our Marketplace. For information on how to advertise your service or product click here. Remote Central reserves the right to remove or modify any post that is deemed inappropriate.

Hosting Services by ipHouse