Your Universal Remote Control Center
RemoteCentral.com
Philips Pronto Professional Forum - View Post
Previous section Next section Up level
Up level
The following page was printed from RemoteCentral.com:

Login:
Pass:
 
 

Topic:
Odd issue
This thread has 3 replies. Displaying all posts.
Post 1 made on Saturday August 15, 2020 at 01:01
mpg7321
Regular Member
Joined:
Posts:
June 2020
55
So on my main page I have two icons, each icon is set to jump to two different pages. Each page, on the Advanced tabs, I have a script set to run once on page load "Execute once when page is shown" is checked. The commands are to switch inputs on my receiver. GlobalRS232("!1SLI10\x0D"); and GlobalRS232("!1SLI01\x0D"); The library is available system wide. Works on one but not the other. I know both commands work. Switched them up and both work on one page load but not on the other page load.

Any thoughts?
Post 2 made on Saturday August 15, 2020 at 12:34
Lyndel McGee
RC Moderator
Joined:
Posts:
August 2001
12,604
Pages on different activity and socket not yet connected?

System.setDebugMask(9) and System.print show you anything? Did you attempt to debug?

Jon welfringer simulator patch will help with debugging. Did you set it up yet? If not, it is one huge timesaver.
Lyndel McGee
Philips Pronto Addict/Beta Tester
OP | Post 3 made on Saturday August 15, 2020 at 16:25
mpg7321
Regular Member
Joined:
Posts:
June 2020
55
No errors given. Already have the simulator patch installed, so thanks for that info from before. Makes life a lot easier. I ended up deleting the activities and recreating it and then pasting the one page back into it. All works now. I think it was a glitch. For again every thing was set up the same for the one that was working. There where no other scripts running on theses page laods, so not sure what happened.
Post 4 made on Saturday August 15, 2020 at 18:38
Lyndel McGee
RC Moderator
Joined:
Posts:
August 2001
12,604
Too many issues I have seen with the Beta version of PEP3.

Memory Leaks, Image corruption....

My Recommendation - Use PEP2 instead of PEP3 if you are using PEP3.
Lyndel McGee
Philips Pronto Addict/Beta Tester


Jump to


Protected Feature Before you can reply to a message...
You must first register for a Remote Central user account - it's fast and free! Or, if you already have an account, please login now.

Please read the following: Unsolicited commercial advertisements are absolutely not permitted on this forum. Other private buy & sell messages should be posted to our Marketplace. For information on how to advertise your service or product click here. Remote Central reserves the right to remove or modify any post that is deemed inappropriate.

Hosting Services by ipHouse