Your Universal Remote Control Center
RemoteCentral.com
Philips Pronto Professional Forum - View Post
Previous section Next section Up level
Up level
The following page was printed from RemoteCentral.com:

Login:
Pass:
 
 

Topic:
TSU9800 with Anthem AV receiver
This thread has 13 replies. Displaying all posts.
Post 1 made on Monday February 17, 2020 at 22:44
blackmajor
New Member
Joined:
Posts:
February 2020
5
Hi, I hope someone can help me with this. My Anthem MRX-720 AV receiver cannot be controlled with the TSU9800 yet. My setup is through an RFX9600 extender, many other equipment and commands work, but nothing on the MRX-720.
I find it strange that the manufacturers Pronto HEX code is highly different from what the TSU9800 learns when running through IR code learning. This is power on for example:
Manufacturers code (from Anthem website):
0000 006D 0022 0002 0155 00AA 0015 0040 0015 0015 0015 0040 0015 0015 0015 0015 0015 0015 0015 0015 0015 0040 0015 0015 0015 0040 0015 0015 0015 0040 0015 0015 0015 0040 0015 0040 0015 0015 0015 0040 0015 0040 0015 0040 0015 0015 0015 0040 0015 0015 0015 0015 0015 0040 0015 0015 0015 0015 0015 0015 0015 0040 0015 0015 0015 0040 0015 0040 0015 0015 0015 05ED 0155 0055 0015 0E47
Learning from original remote :
0000 006C 0022 0002 0158 00AB 0016 0040 0016 0015 0016 0040 0016 0015 0016 0015 0016 0015 0016 0015 0016 0040 0016 0015 0016 0040 0016 0015 0016 0040 0016 0015 0016 0040 0016 0040 0016 0015 0016 0040 0016 0040 0016 0040 0016 0015 0016 0040 0016 0015 0016 0015 0016 0040 0016 0015 0016 0015 0016 0015 0016 0040 0016 0015 0016 0040 0016 0040 0016 0015 0016 062A 0158 0055 0016 0E60
None of these work, and none of the functions work, but only for this Anthem AV receiver. I do not understand the difference above either.
Can someone help me solving this please ? Thank you,
Post 2 made on Tuesday February 18, 2020 at 11:03
buzz
Super Member
Joined:
Posts:
May 2003
3,356
A quick reality check: Many phone/pad cameras will capture IR. First, make sure that your phone/pad can capture IR, then check to make sure that the IR emitter assigned to the Anthem is actually emitting IR when you expect.
Post 3 made on Wednesday February 19, 2020 at 09:43
Barf
Long Time Member
Joined:
Posts:
August 2013
233
@blackmajor
Looks like the sending os fawlty. The test by buzz is a first test.

the manufacturers Pronto HEX code is highly different from what the TSU9800 learns

No it is not. The numbers (except for the first four) are all duration lengths in periods, and vary just "a little". You can use IrScrutinizer to identify as well as "canoncalize" the signals, You will discover that both decodes to NEC1: {D=133,F=151,S=106}.
Post 4 made on Wednesday February 19, 2020 at 14:56
Lyndel McGee
RC Moderator
Joined:
Posts:
August 2001
12,390
On the RFX9600, set the emitter output level to 'Low' from 'Normal' (a DIP switch on the back) and retest. I am wondering if the signal emitted is too 'hot'.
Lyndel McGee
Philips Pronto Addict/Beta Tester
OP | Post 5 made on Thursday February 20, 2020 at 21:17
blackmajor
New Member
Joined:
Posts:
February 2020
5
Thank you all for the hints. I did multiple things, still no success.
I was sure the IR emitter is working as the other one (on the same lead) was properly controlling another equipment. Of course I was wrong... The one emitter on the Anthem was not working at all. So I replaced with a good one, checking with my iPhone that it emits IR signal. (I had to learn though that only the front facing camera of the iPhone 'sees' IR, not the back facing.)
After having a proper emitter on the Anthem, I tried Normal as well as Low output levels, both with the Anthem manufacturers HEX code and the one learnt from the original remote. Still nothing. I keep trying....
OP | Post 6 made on Thursday February 20, 2020 at 21:40
blackmajor
New Member
Joined:
Posts:
February 2020
5
... one more thing : the Anthem receiver is getting a signal. It goes into a dim display mode after a few seconds automatically, and when the emitter emits IR code, the dim mode goes back to normal. Every time. So signal is received for sure, but no control. I tried several commands, nothing. Except for the original remote - that works perfectly.
OP | Post 7 made on Thursday February 20, 2020 at 22:11
blackmajor
New Member
Joined:
Posts:
February 2020
5
As a real beginner I just found out that the receiver has an IR in jack so I got a mono jack cable and connected the Philips extender jack output to the Anthem IR in jack. Same result : dimming comes back to normal but no command is executed.
Post 8 made on Friday February 21, 2020 at 17:42
Lyndel McGee
RC Moderator
Joined:
Posts:
August 2001
12,390
Go here and download the Control 4 driver.

[Link: drivers.control4.com]

rename the file to .xml and then open in a text editor.

Search for 0000 0067

There you will find the Pronto Hex as officially used by Control 4.

My recommendation would be to test 1 or 2 codes. Start with line 1557 of the file

<ircode>
<name>POWER_ON</name>
<transmit>PULSE</transmit>
<repeatcount>5</repeatcount>
<delayafter>0</delayafter>
<pattern>0000 0067 0022 0002 0156 00ab 0016 003f 0016 0016 0016 003f 0016 0016 0016 0016 0016 0016 0016 0016 0016 003f 0016 0016 0016 003f 0016 0016 0016 003f 0016 0016 0016 003f 0016 003f 0016 0016 0016 003f 0016 003f 0016 003f 0016 0016 0016 003f 0016 0016 0016 0016 0016 003f 0016 0016 0016 0016 0016 0016 0016 003f 0016 0016 0016 003f 0016 003f 0016 0016 0016 0593 0160 0058 0016 0dc0</pattern>
<altpattern />
</ircode>
Lyndel McGee
Philips Pronto Addict/Beta Tester
Post 9 made on Friday February 21, 2020 at 17:49
Lyndel McGee
RC Moderator
Joined:
Posts:
August 2001
12,390
If the code above works, then lift the other codes as needed from this file. If not, then try adjusting the 'Duration' setting in the PEP2 database for the code. For example, in the file, it appears that Control4 may repeat a code 5 times.

FYI, I found the driver location via a google search with keywords

multiple codesets anthem receiver

Here's the link containing file from above.

[Link: drivers.control4.com]

To get the file, I expanded:

Anthem MRX 700 [Serial][IR]

What I find funny is that the MRX700 driver in Control4 land appears to have a timing marker that I'd normally see in Sony codes (0067) where as 006D is NEC timing.



I also just located the file you referenced on AnthemAv.com

On the hex codes tab, there are shorthand versions of the NEC1 codes.

Can you also see if either of these work?

'on'

900A 006D 0000 0001 856A 9768

'off'
900A 006D 0000 0001 856A 936C

Last edited by Lyndel McGee on February 21, 2020 18:02.
Lyndel McGee
Philips Pronto Addict/Beta Tester
Post 10 made on Saturday February 22, 2020 at 22:56
Lyndel McGee
RC Moderator
Joined:
Posts:
August 2001
12,390
Any updates???
Lyndel McGee
Philips Pronto Addict/Beta Tester
OP | Post 11 made on Sunday February 23, 2020 at 19:18
blackmajor
New Member
Joined:
Posts:
February 2020
5
Hi, thank you for all that help. Appreciate you took the time.
So I tried all that as your wrote. No success. I also followed your method and searched for other Control4 files for this model and others. Nothing worked.
Actually the proper MRX720 Control4 file was in c4z format, not as c4i. I was unable to take out the MRX720 codes from the c4z file. Do you have any means for that ?

[Link: annex4.link]

There is also some other ones in this ZIP :

[Link: anthemav.com]


I actually think about calling Anthem technical support tomorrow. And I ordered another IR emitter wire so that I can replace that. I also checked that the receiver has the latest firmware installed.
Thank you for all the help you provide.
Post 12 made on Monday February 24, 2020 at 14:24
arthurpotts
Long Time Member
Joined:
Posts:
November 2002
74
I have an AVM 50v and am using the same codes from my AVM 20, and they work faultlessly. I don't know if the codes are the same for your Anthem. If so, I can send what I have that is working. I am using these codes in PEP 3, on two TSU9600 and a TSU9800 all through several RFX9600.
Post 13 made on Monday February 24, 2020 at 18:46
Lyndel McGee
RC Moderator
Joined:
Posts:
August 2001
12,390
I have experience in the past with some equipment that if RS232 is connected to a device, the IR receiver can be disabled.

Also, on my Marantz/Denon equipment, the web interface prevents the IR emitter from accepting input. I am wondering if you might be experiencing something like this as well.

Hopefully, you will get some info from Anthem tech support.
Lyndel McGee
Philips Pronto Addict/Beta Tester
Post 14 made on Monday March 2, 2020 at 18:01
Lyndel McGee
RC Moderator
Joined:
Posts:
August 2001
12,390
Bump! Any updates from Anthem?
Lyndel McGee
Philips Pronto Addict/Beta Tester


Jump to


Protected Feature Before you can reply to a message...
You must first register for a Remote Central user account - it's fast and free! Or, if you already have an account, please login now.

Please read the following: Unsolicited commercial advertisements are absolutely not permitted on this forum. Other private buy & sell messages should be posted to our Marketplace. For information on how to advertise your service or product click here. Remote Central reserves the right to remove or modify any post that is deemed inappropriate.

Hosting Services by ipHouse