Your Universal Remote Control Center
RemoteCentral.com
Philips Pronto Professional Forum - View Post
Previous section Next section Up level
Up level
The following page was printed from RemoteCentral.com:

Login:
Pass:
 
 

Topic:
Problem after changing over a TSU9600 touch screen
This thread has 4 replies. Displaying all posts.
Post 1 made on Friday May 31, 2019 at 07:22
NBTBRV8
New Member
Joined:
Posts:
May 2019
10
Guys,

I need help with this one. My touch screen failed in the TSU9600 so I bought a donor unit and pulled the screen out of it. Upon putting it back together I now find that the screen lights up and you can touch it and it works, but the screen does not display an image. It obviously has power but it just doesn't display anything.

After dozens of attempts at seating the circuit ribbon only once did it display the screen images, but in a really washed out set of colours. I have tried putting my old screen back in it, but that two does the same as the above, so I don't think it is a faulty screen.

If nobody knows how to fix it, can anybody recommend a repairer anywhere in the world?

I no longer have the file to load on a replacement unit, so I need to get it repaired.

Thanks
Post 2 made on Saturday June 1, 2019 at 02:45
Twelfth Monkey
Regular Member
Joined:
Posts:
November 2016
55
Was the screen working whilst it was still on the donor unit? If so, and because both screens show the same problem, it might be the unit rather than the screen.

Obviously I hope that isn't the case!
OP | Post 3 made on Saturday June 1, 2019 at 06:35
NBTBRV8
New Member
Joined:
Posts:
May 2019
10
I never powered up the donor unit unfortunately. The touch screen appears to work, but I can't get it to display an image.

I am also finding another fault now, it will sit on the cradle and beep like the screen is being pressed and the tv will respond.

As per my other thread, I am now contemplating looking for an alternative system to replace the Pronto. But I don't know what to use.
Post 4 made on Saturday June 1, 2019 at 16:58
Lyndel McGee
RC Moderator
Joined:
Posts:
August 2001
12,289
if it is sitting there beeping, then likely you did not snap the old screen into the black plastic bezel properly and the bezel or screen is exerting minor pressure on the back of the touchscreen. Take it apart and remount it.
Lyndel McGee
Philips Pronto Addict/Beta Tester
OP | Post 5 made on Saturday June 1, 2019 at 20:06
NBTBRV8
New Member
Joined:
Posts:
May 2019
10
It was beeping before I changed the screen over in the old remote and the touch screen wasn't working at all. That is why I thought the screen had packed it in.

So I am guessing the board too has a fault.

I have now found out that another Pronto remote in the house is doing a very similar thing, everything is now pointing to me having to ditch it, but I don't know what to replace it all with whilst keeping the core of the setup, I.e. I don't want to have to spend heaps of money doing a major home entertainment change.


Jump to


Protected Feature Before you can reply to a message...
You must first register for a Remote Central user account - it's fast and free! Or, if you already have an account, please login now.

Please read the following: Unsolicited commercial advertisements are absolutely not permitted on this forum. Other private buy & sell messages should be posted to our Marketplace. For information on how to advertise your service or product click here. Remote Central reserves the right to remove or modify any post that is deemed inappropriate.

Hosting Services by ipHouse