Your Universal Remote Control Center
RemoteCentral.com
Philips Pronto Professional Forum - View Post
Previous section Next section Up level
Up level
The following page was printed from RemoteCentral.com:

Login:
Pass:
 
 

Topic:
Back to Pronto, software advice needed.
This thread has 11 replies. Displaying all posts.
Post 1 made on Friday August 24, 2018 at 09:24
bert003
Long Time Member
Joined:
Posts:
January 2008
76
After many years, I bought back a Pronto, this time a TSU9600.
I sold my previous Pronto Pro, a TSU9400, after Philips announced to stop making them.
After that I used my old 2 RU960 Pronto's and recently a NEEO after 2,5 years waiting since their Kickstarter campaign started. The NEEO was a dissappointment for me so I sold it.

But now I will start to create a new configuration for the 9600.

Which software version shall I use? Is v3 stable or should I better use v2?

I have no programming skills but I would like to send out HTTP GET commands to control some Wifi radio's I use. Is this possible?

Thanks!
Post 2 made on Friday August 24, 2018 at 18:13
Lyndel McGee
RC Moderator
Joined:
Posts:
August 2001
12,217
I recommend you use PEPv2 if possible and you don't want to use Overlays as the PEPV3 software was beta and had some memory leaks which could cause you to lose changes in a config. You can still use the latest TSU9600/RFX9600 firmware but stick with PEPv2 as the editor.


For your 2nd question, HTTP and not HTTPS is possible and I would recommend you start a separate thread for that.
Lyndel McGee
Philips Pronto Addict/Beta Tester
OP | Post 3 made on Saturday August 25, 2018 at 05:37
bert003
Long Time Member
Joined:
Posts:
January 2008
76
Hi Lyndel,

Thanks for your advise, I will start with PEPv2. The latest firmware is on the device.

I mostly will use the Pronto for IR commands since I am not a programmer. But maybe with some help I can do some more. I have a Z-wave domotica controller which can also be controlled by an Android app named Tasker.

If I can manage to send commands by the Pronto through my network which Tasker can use them as triggers, a new world of possibilities opens. But I have to check if Tasker could do that. Ofcoarse I will ask new questions in a new thread.

Thanks!
OP | Post 4 made on Saturday August 25, 2018 at 09:31
bert003
Long Time Member
Joined:
Posts:
January 2008
76
Well, I am running into troubles already with PEPv2.

I have installed PEPv1, 2 and 3 on my Win10 laptop.
Until now I was testing a bit with PEPv3.

But now I want to use PEPv2 and it seems like I cn't upload a config to the 9600. "C5, HID not found". I have tried several solutions as read in threads regarding this error but without luck.

I even downgraded the firmware from v7.4.22 to v7.3.3, but PEPv2 keeps giving me this HID not found error.

Is there a known solution for PEPv2? I tried several compatibility settings (win 7, vista, win 8), uninstalling PEPv3, rebooting the computer, the Pronto, but nothing seems to work.

If I have to use PEPv3 and don't use overlay pages, and keep firmware v7.3.3, will I be safe then?
Post 5 made on Saturday August 25, 2018 at 11:15
Lowpro
Select Member
Joined:
Posts:
March 2004
2,028
This is a known issue. There are a multitude of forum posts about this. Perform a forum search. That being said, I experience this issue as well. I've experienced it since moving from Windows XP to Windows 7. I use a laptop in conjunction with an external keyboard and mouse. I'm running PEP v1.1.20 and Windows 7 Professional 64-bit. With my external keyboard and mouse connected I get the error. If they're not connected I don't get the error. No issues downloading (Ctrl+D) to my TSU9600's so long as I disconnect my external keyboard and mouse first.
LP Related Links:
View my profile to access various
links to key posts and downloads.
OP | Post 6 made on Saturday August 25, 2018 at 12:18
bert003
Long Time Member
Joined:
Posts:
January 2008
76
I use a laptop, there is not much to turn off I guess. I tried to turn of the touchpad and use a mouse. But there are about 20 HID devices in the device manager. I am afraid if I turn them off the whole computer becomes uncontrollable.

I see the same error with PEPv1, didn't test it yet.

I could try an old Win7 virtual machine, but I'd rather use my Windows 10 machine directly.

Is there a 100% chance that if I just use PEPv3, maybe with an older firmware, and don't use overlay pages, I will get a memory leak error when my config is getting bigger?
Post 7 made on Saturday August 25, 2018 at 13:39
Lowpro
Select Member
Joined:
Posts:
March 2004
2,028
I can't speak to PEP 2/3. I use PEP v1.1.20 exclusively. That being said, there may just be a couple key "HID-compliant" device drivers that you need to disable. Your touchpad will continue to work regardless. I'd start by disabling any "HID-compliant mouse" drivers that are present in addition to ensuring you don't have an external keyboard and mouse connected. Also make sure to look through the many forum threads here on this. They'll more than likely prove fruitful. Good luck.
LP Related Links:
View my profile to access various
links to key posts and downloads.
OP | Post 8 made on Saturday August 25, 2018 at 14:51
bert003
Long Time Member
Joined:
Posts:
January 2008
76
I have about 35 devices in the section Human Input Devices in the device manager. Most of them have generic or the same names. Hard to identify. Feels like Russian roulette to disable them, maybe tomorrow.

And in the mean time I got my first "exception error" while saving the config in PEPv3.

I have spent a few hours with reading threads about this issue.
And I found a small section in the help directory about the Pronto being a mass storage device.

But enough for today, a whole day is lost already :-)
Post 9 made on Saturday August 25, 2018 at 15:16
Lowpro
Select Member
Joined:
Posts:
March 2004
2,028
Do you have any "HID-compliant mouse" devices under "Mice and other pointing devices"? Those are the only ones I have disabled in the past if memory serves me correctly. And perhaps you should try PEP v2 as Lyndel suggested. The latest isn't always the greatest. PEP v3 wasn't out very long prior to the Pronto line being closed. Personally I don't even care for PEP v2. It's PEP v1.1.20 for the win as far as I'm concerned, but to each his own.
LP Related Links:
View my profile to access various
links to key posts and downloads.
OP | Post 10 made on Sunday August 26, 2018 at 08:01
bert003
Long Time Member
Joined:
Posts:
January 2008
76
I have turned of the devices under "Mice and other pointing devices" which can be turned off. I guess the active devices can't be turned off, so the active mouse and keyboard remain enabled.

The problem is not that I want to use PEPv3, I want to use PEPv2 and the problems are with PEPv2 and PEPv1.
PEPv3 has no problems with uploding a config tot the Pronto or learning IR codes. But since PEPv3 is not stable I would like to use PEPv2.

As workaround I now use a sync program that backups my config file with a time stamp added to the filiname. So each time I save the config a filecopy is done. So I should always have the last working version if PEPv3 crashes.

Another option which might work is learning the IR codes with PEPv3 into the database. The database seems the same in PEPv2 and PEPv3.
After that I can create my config with PEPv2. If I want to upload it to the Pronto I have to open PEPv3, import the XCF and upload it to the Pronto. I have to test if this works 100%.

PEPv1 would be fine for me to, but since I have the same connection error with v1 too, it is not an option.
Post 11 made on Sunday August 26, 2018 at 10:08
Lowpro
Select Member
Joined:
Posts:
March 2004
2,028
Roger that. Well good luck.
LP Related Links:
View my profile to access various
links to key posts and downloads.
Post 12 made on Tuesday September 4, 2018 at 13:34
Lyndel McGee
RC Moderator
Joined:
Posts:
August 2001
12,217
For most reliable learning capabilities, do 'Quick Learn'. To do this, you create multiple functions under the component then 'Quick Learn' them 1 by one.
Lyndel McGee
Philips Pronto Addict/Beta Tester


Jump to


Protected Feature Before you can reply to a message...
You must first register for a Remote Central user account - it's fast and free! Or, if you already have an account, please login now.

Please read the following: Unsolicited commercial advertisements are absolutely not permitted on this forum. Other private buy & sell messages should be posted to our Marketplace. For information on how to advertise your service or product click here. Remote Central reserves the right to remove or modify any post that is deemed inappropriate.

Hosting Services by ipHouse