Your Universal Remote Control Center
RemoteCentral.com
Philips Pronto Professional Forum - View Post
Previous section Next section Up level
Up level
The following page was printed from RemoteCentral.com:

Login:
Pass:
 
 

Topic:
Please sell me your spare/NIB TSU9300
This thread has 6 replies. Displaying all posts.
Post 1 made on Monday April 23, 2018 at 07:49
Doug G
Lurking Member
Joined:
Posts:
April 2004
6
I noticed my TSU9300 was draining the battery much, much faster than usual the past couple of days so I power cycled it to reboot and now it won't load. That wasn't entirely unexpected, so as usual I force loaded fw to recover as I've done many times in the past. Tried versions 7.0.18 and 7.3.3, both of which appear successful, but after application load and reboot get stuck at the "Please wait..." screen (after the beeps/animation) and it just hangs. ProntoEdit won't connect, says the unit is "config mode". Tried removing the battery, which is fully charged, but no joy. Buttons don't do anything, and it shows up as a drive/device but isn't really there since no status/properties are possible.

At this point it appears to be irreparably broken. It would act funny now and then, sometimes shooting off codes or waking up all on its own, or sometimes codes would get randomly corrupted and I'd have to reprogram.

I'm hoping someone has a spare/NIB/"like new" (meaning not really ever used) TSU-9300 that you'd consider selling. If so, please contact me.

I'm completely despondent at this point, it was the core of my entire AV and X10 home automation and with no equivalent available, I have no idea what I'm going to do.
Post 2 made on Tuesday April 24, 2018 at 03:12
cosmicvoid
Long Time Member
Joined:
Posts:
November 2007
90
If you fail to find a TSU9300, maybe you could consider a TSU9400. The screen resolution is the same, and the specs are very similar, and I'm guessing there is some code compatability. The 9400s are on ebay for a reasonable price.

Or maybe you could dismantle the 9300 and discover a flaky connection somewhere, else nothing to lose. I've seen stories about Prontos developing bad solder connections.
OP | Post 3 made on Tuesday April 24, 2018 at 08:16
Doug G
Lurking Member
Joined:
Posts:
April 2004
6
About 5 years ago when I thought it was dead before I learned about the force firmware download recovery, I actually did have it apart and took the control board to work and looked at it under the scope in the HW lab but everything seemed clean. I'm a EE (who now writes SW, lol) with plenty of soldering experience but re-flowing fine pitch devices as used here can get really tricky.

But like you said at this point nothing to lose so I think I will just pull it and try to re-flow everything.

Can someone tell me what size torx bit is needed to get the screws out? Last time I think I used a flat head from a jewelers set which I don't seem to have any longer.
Post 4 made on Wednesday April 25, 2018 at 16:31
Lyndel McGee
RC Moderator
Joined:
Posts:
August 2001
12,236
I believe will be a T6 torx
Lyndel McGee
Philips Pronto Addict/Beta Tester
Post 5 made on Sunday April 29, 2018 at 06:11
buzz
Super Member
Joined:
Posts:
May 2003
2,873
I’m curious about battery condition. Watch the battery voltage with a scope.

If you decide to jump ship and move to a different platform, look into TouchControl. The runtime platform is iOS, therefore you can take advantage of screen interactions that are not possible, or practical with Pronto (much faster hardware).

This is not a one for one replacement for Pronto, it’s a different paradigm, but you may be able to reuse some of your code. Since iPad/iPhone cannot emit IR, you’ll need a “box”. In the United States, Global Caché is a good choice.

Last edited by buzz on April 29, 2018 06:45.
OP | Post 6 made on Tuesday May 1, 2018 at 09:29
Doug G
Lurking Member
Joined:
Posts:
April 2004
6
It lives!

Checked it under the scope at work and still found no obvious cold solders or shorts. With most of the devices being fine pitch flat packs, 0402 discretes, or BGAs I can't even get to, decided re-flowing wasn't likely to yield results so just brought it home.

Was fiddling with it yesterday and decided I'd try to use older fw hoping that maybe there was a bad bit in the flash memory that might get twiddled, and when I hooked it up to my USB and powered it up, didn't all the lights come on after the confirmation beeps! I about lost my mind. I turned it off, put on just the screen, and powered back on and wasn't it sitting at the screen calibration! So I carefully put it all back together (after lubing up the wheel bearings and cleaning all screens) and it booted! I did the screen cal then was able to download my config in it. This doesn't feel like a cold solder to me, feels more like bad memory (RAM or flash) or bit flip kind of thing. Cold solders tend to be fairly permanent until rectified.

For those who also got stuck "in configuration mode", this appears to be the initial config which is done when no config/app exists, including the screen cal. That screams to me that the application got corrupted in memory somehow. Or possibly its own config settings in nvram.

So for now I'm back in business. I won't be powering it off ever again, unless the fw or config absolutely won't take and I have no choice.
Post 7 made on Monday May 28, 2018 at 20:29
gopronto
Senior Member
Joined:
Posts:
April 2008
1,437
i have spares fro the tsu9300, but the shipping costs may make it to expensive.

regards

Mark
Pronto still one of the best Wi-Fi Remotes,
www.ikonavs.co.nz and [Link: prontoprojects.com] Axium Control catching up fast :)


Jump to


Protected Feature Before you can reply to a message...
You must first register for a Remote Central user account - it's fast and free! Or, if you already have an account, please login now.

Please read the following: Unsolicited commercial advertisements are absolutely not permitted on this forum. Other private buy & sell messages should be posted to our Marketplace. For information on how to advertise your service or product click here. Remote Central reserves the right to remove or modify any post that is deemed inappropriate.

Hosting Services by ipHouse