Your Universal Remote Control Center
RemoteCentral.com
Complete Control by URC Forum - View Post
Previous section Next section Previous page Next page Up level
Up level
The following page was printed from RemoteCentral.com:

Login:
Pass:
 
 

Page 3 of 3
Topic:
How to communicate with a 'dead' MX-990
This thread has 31 replies. Displaying posts 31 through 32.
OP | Post 31 made on Saturday January 27, 2018 at 17:33
cgroth
Founding Member
Joined:
Posts:
April 2002
470
Downloading works fine (only issue is that sound files somehow become deactivated on every second download). It is after updating the software the issue arises (or it has done on the last two occasions, but probably not a solid enough statistical basis for drawing a conclusion as to the cause). However, rather than getting into a fight with URC and spending lots of money is shipping, and being without the remote for weeks), I'll just not update the software and hope it will be stable...
Post 32 made on Tuesday January 22, 2019 at 14:57 ...it's new!
redridged
It's my first day!
Joined:
Posts:
January 2019
1
One problem with this otherwise excellent remote (I have several) is the dreaded micro USB port fragility (who knew). They simply do not hold up physically. I have two that require holding upside down "just so" with a steady hand during the upload/download process. A couple of them require "weighting" the cable by placing a small object under the cable near the remote to bias the connection upward or downward. One good visual indicator is the yellow (current being drawn) LED on the charging cable (available everywhere with charging LEDs) and the continual confirmation screen on the remote. If it goes dark you do not have a full data transfer connection.

Has anyone opened the 990's case and seen if there is good access for soldering in a replacement jack? I think a swap back to the mini (rather than micro) would be a more reliable long term solution.

Also is the MX-990 still being manufactured? The whole Complete Control line for that matter? The CC line has disappeared from my local dealer distributor's website.

I've been off this forum so long I forgot my old user name!

Last edited by redridged on January 22, 2019 15:32.
Page 3 of 3

Jump to


Protected Feature Before you can reply to a message...
You must first register for a Remote Central user account - it's fast and free! Or, if you already have an account, please login now.

Please read the following: Unsolicited commercial advertisements are absolutely not permitted on this forum. Other private buy & sell messages should be posted to our Marketplace. For information on how to advertise your service or product click here. Remote Central reserves the right to remove or modify any post that is deemed inappropriate.

Hosting Services by ipHouse