Your Universal Remote Control Center
Complete Control by URC Forum - View Post
Previous section Next section Previous page Next page Up level
Up level
The following page was printed from


Page 2 of 2
Solution to those who can not connect MX-980 with CCP
This thread has 19 replies. Displaying posts 16 through 20.
Post 16 made on Saturday March 2, 2019 at 12:20
Long Time Member
June 2011
On January 3, 2018 at 23:45, Diamond Dog said...
Looks like a Windows 10 update messed things up. I could not see " "Windows Mobile-2003 based device connectivity" anymore. Reinstalled WMDC and then went through the steps in the original post and it worked.

Wonder if this post should be a "sticky"?

I can't see the "2003 based device connectivity" line either. I also can't download WMDC. It says there's a dvrupdate-amd64 error. Any suggestions?
OP | Post 17 made on Sunday December 1, 2019 at 12:38
Diamond Dog
Long Time Member
May 2003
On March 2, 2019 at 12:20, KenSmith58 said...
I can't see the "2003 based device connectivity" line either. I also can't download WMDC. It says there's a dvrupdate-amd64 error. Any suggestions?

HA! I had to come back here to read my own instructions to get my remote to sync as I just updated some programming.

Your remote has to be on and running for the "Windows MObile-2003 based..." option. It won't appear if the remote sleeps.

I am glad this instruction manual has helped a lot of people.

I have a backup of my CCP but should it ever fail and I loose CCP, my only ask is that some kind soul helps me if they feel I helped them (I obviously have the program now)
Post 18 made on Saturday May 30, 2020 at 17:13
Robert Parker
Senior Member
March 2004
Update on 5/30/2020
I'm running Windows 10 ver 18362
After doing everything in this thread I can connect. I'm not sure that all steps were needed but I did the following.
1) Change the CCP program to run as administrator under compatibility settings. Then run the MDC installer from within CCP

2) Under computer management changed both
Windows Mobile-2003-based device connectivity
Windows Mobile-based device connectivity
to Log On using the Local System Account and checked allow service to interact with desktop. Additionally under recovery I changed all failures to Restart the Service.

3) Applied both registry patches from the stackoverflow link.

REG ADD HKLM\SYSTEM\CurrentControlSet\Services\RapiMgr /v SvcHostSplitDisable /t REG_DWORD /d 1 /f

REG ADD HKLM\SYSTEM\CurrentControlSet\Services\WcesComm /v SvcHostSplitDisable /t REG_DWORD /d 1 /f

from a command prompt. You must run the cmd app as an administrator for this to work.

4) From device manager find the unknown device that will show up when you plug in your remote. In my case a MX980. Install the driver from the list in the CCP program file location.

Now it works. Yea!
Clatto Verata... Necktie
Post 19 made on Monday August 17, 2020 at 19:21
New Member
August 2020
This is what I was able to get to work

1) Go to Control Panel > Programs > Programs and Features and click on Turn Windows features on or off.

2) Check the boxes for .NET Framework 3.5 and press OK.

3) Change the CCP program to run as administrator under compatibility settings.

4) Then run the MDC installer from within CCP (green circle at top under tools tab)

5) Click on Start, and then click on Computer Management > Services & Applications > Services. Scroll down to right-click on "Windows Mobile-2003-based device connectivity" to select Properties > Log On. Switch to "Local System account" with checking "Allow service to interact with desktop" then click OK.

Thanks for everyone's help over the years. This forum has saved me many times.

Last edited by Bradford on August 17, 2020 19:39.
Post 20 made on Wednesday September 2, 2020 at 23:21
New Member
September 2020
I am running the Mx-980 Editor (beta) and have been going through these forums in an attempt to update my remote. I am running Win 10 and can not download WMDC. I have tried to update the drivers but Wins indicates it has already installed the preferred driver. I've enabled Offline files. I've enabled .NET 3.5. I've run the editor as an administrator when launching.

I still get an error when trying to download the settings to the remote. Forever grateful if someone can provide some direction. What am I missing?
Page 2 of 2

Jump to

Protected Feature Before you can reply to a message...
You must first register for a Remote Central user account - it's fast and free! Or, if you already have an account, please login now.

Please read the following: Unsolicited commercial advertisements are absolutely not permitted on this forum. Other private buy & sell messages should be posted to our Marketplace. For information on how to advertise your service or product click here. Remote Central reserves the right to remove or modify any post that is deemed inappropriate.

Hosting Services by ipHouse