Your Universal Remote Control Center
RemoteCentral.com
Complete Control by URC Forum - View Post
Previous section Next section Previous page Next page Up level
Up level
The following page was printed from RemoteCentral.com:

Login:
Pass:
 
 

Page 1 of 2
Topic:
MX-850 Comm Error
This thread has 19 replies. Displaying posts 1 through 15.
Post 1 made on Thursday November 11, 2010 at 18:55
winesmile
Active Member
Joined:
Posts:
August 2007
580
I've read some posts on this issue, but they're a few years old so maybe some fresh eyes can help me out.

We don't do very much URC programming anymore, but I have a client with an MX-850 that I need to make a change too.

When connecting my USB serial cable WIN XP does recognize it, but I keep getting error code: 100-07UU-0000 saying my Comm port is incorrect.  No matter what setting I change the port to on the PC.

I have successfully connected to another clients MX-850 successfully so this cable has worked.

I am using the old MX-850 specific software as it doesn't look like the CCP software supports the MX-850...  According to the splash screen on install...

Any help you can lend is appreciated!

Last edited by winesmile on November 12, 2010 14:03.
Post 2 made on Thursday November 11, 2010 at 22:20
JoeFlabitz
Select Member
Joined:
Posts:
December 2008
1,517
On November 11, 2010 at 18:55, winesmile said...
I've read some posts on this issue, but they're a few years old so maybe some fresh eyes can help me out.

We don't do very much URC programming anymore, but I have a client with an MX-850 that I need to make a change too.

When connecting my USB serial cable WIN XP does recognize it, but I keep getting error code: 100-07UU-0000 saying my Comm port is incorrect.  No matter what setting I change the port to on the PC.

I have successfully connected to another clients MX-850 successfully so this cable has worked.

I am using the old MX-880 specific software as it doesn't look like the CCP software supports the MX-880...  According to the splash screen on install...

Any help you can lend is appreciated!

So which is it?
MX850
or
MX880
OP | Post 3 made on Friday November 12, 2010 at 14:03
winesmile
Active Member
Joined:
Posts:
August 2007
580
My mistake!

MX-850
Post 4 made on Friday November 12, 2010 at 17:02
tweeterguy
Loyal Member
Joined:
Posts:
June 2005
7,713
What usb to serial adaptor? The only one I use and recommend is the iogear guc232a, others may work but that one has never failed me. Have you tried another URC cable? Sometimes they go bad too. And have you gone into the device hardware settings in XP to check when it is plugged in that it is recognized and operating correctly? Are you sure the usb driver is loaded properly for the adaptor? Tried to uninstall and reinstall the driver? Tried using the serial adaptor on another device to communicate with via terminal or other serial communication software?
Post 5 made on Friday November 12, 2010 at 21:39
Ernie Bornn-Gilman
Yes, That Ernie!
Joined:
Posts:
December 2001
29,774
The only one I've ever used is the Keyspan, recommended in the Pronto fora as never failing... and it has never given me any problems with any of the Pronto units I've used it with.

I find the MX850 must be done this way, and then it ALWAYS works:

*connect adaptor
*connect MX850
*open editing program
*try to download
*when it fails, change the port to something or other, not 1
*try to download
*when it fails, change the port to 1
*enjoy your success
*if you disconnect the MX850 after this, expect to repeat this process

This probably has more steps than are necessary, but it always works. I don't want to spend the time paring down the steps to the absolute minimum, because if I find in the field later that I made a mistake, I'll have to come back to this list. So I just submit. And do it.
A good answer is easier with a clear question giving the make and model of everything.
"The biggest problem in communication is the illusion that it has taken place." -- G. “Bernie” Shaw
OP | Post 6 made on Friday November 12, 2010 at 22:28
winesmile
Active Member
Joined:
Posts:
August 2007
580
Thanks guys I'll give this a shot... 
Post 7 made on Sunday August 7, 2011 at 09:44
haggisbingo
Long Time Member
Joined:
Posts:
December 2009
10
Ernie,

This really works!!! Thank you! I've struggled to no end with this connection on this remote. (I wonder if this faulty stuff is built in to support installers business or can the software really be that crappy??)

**IMPORTANT** - do not buy a new cable until you try Ernie's instructions



On November 12, 2010 at 21:39, Ernie Bornn-Gilman said...
The only one I've ever used is the Keyspan, recommended in the Pronto fora as never failing... and it has never given me any problems with any of the Pronto units I've used it with.

I find the MX850 must be done this way, and then it ALWAYS works:

*connect adaptor
*connect MX850
*open editing program
*try to download
*when it fails, change the port to something or other, not 1
*try to download
*when it fails, change the port to 1
*enjoy your success
*if you disconnect the MX850 after this, expect to repeat this process

This probably has more steps than are necessary, but it always works. I don't want to spend the time paring down the steps to the absolute minimum, because if I find in the field later that I made a mistake, I'll have to come back to this list. So I just submit. And do it.
Post 8 made on Friday January 20, 2012 at 15:10
Joe R
Lurking Member
Joined:
Posts:
August 2009
3
THANK YOU, THANK YOU, THANK YOU!!!
Joe R
Post 9 made on Sunday August 19, 2012 at 17:38
kenhallock
Lurking Member
Joined:
Posts:
August 2012
2
I have tried this numerous times and I keep getting the message the com port is being used by another program. exit the program that is using the com port. I have no other program using the com port that I am aware of.
Post 10 made on Sunday August 19, 2012 at 18:59
jba1001
Lurking Member
Joined:
Posts:
December 2006
2
I purchased a Rosewill RC-301 "2 Port Serial PCI Adapter" for my desktop computer which is running Win 7. It works without a hitch unless you are actually running another program which uses the com port.

Below, I've inserted a quote from a Q&A response which used to be on the URC website.

"My MX-Editor software and remote are not communicating. What do I do?
Typically, there are a few reasons for this problem. The number one problem we have found is the use of Active Sync or Hot Sync software that is holding on to the active com ports and preventing your PC from communicating with the MX-700. Some digital camera software or software for wireless docking stations, keyboards, or mice can also prevent communication with your MX-800. You may have to disable or even remove the software that is blocking communication with your MX-800.
Alternately, the MX-Editor and computer port may not be set to communicate properly, or you may have a bad cable connection.

Here is the best way to check to see if your settings are correct:
1.In MX-Editor click "COMMUNICATIONS"
2.Click "SETTINGS"
3.Write down the COM PORT NUMBER
4.Go to your Windows Device Manager (Usually found under "Control Panel", "System", then the "Hardware" tab)
5.Click the "+" next to "PORTS"
6.Find the port that has "(COM ...)" at the end of it and make sure it matches the COM Port number you wrote down in step 3
7.If the number matches, right click on that port and select "PROPERTIES"
8.Select the "PORT SETTINGS" tab
9.The settings should read as follows:

Bits per second: 9600
Data bits: 8
Parity: None
Stop bits: 1
Flow Control: None
Click "ADVANCED"
Make sure "Use FIFO buffers..." is CHECKED
Make sure both sliders for "RECEIVE BUFFERS" and "TRANSMIT BUFFERS" are all the way to the right
Make sure the "COM PORT NUMBER" matches the Com Port you wrote down in step 3
Click "OK" until you have closed the Device Manager and Control Panel
10.Reopen the MX-Editor software and test it by attempting to do a download to the remote (Full Download) "

Hope this helps.
Post 11 made on Monday August 20, 2012 at 10:02
musictoo
Active Member
Joined:
Posts:
January 2005
537
Make sure that there isn't another instance of the editor software running in the background. Go to task manager and make sure mxedit.exe isn't a running process with the editor closed. This will happen sometimes when you plug the serial adapter in after you open the editor. Stop the process if it is running, make sure the adapter is plugged in and reopen the editor.


On August 19, 2012 at 17:38, kenhallock said...
I have tried this numerous times and I keep getting the message the com port is being used by another program. exit the program that is using the com port. I have no other program using the com port that I am aware of.
Post 12 made on Thursday October 25, 2012 at 12:53
myerss
Lurking Member
Joined:
Posts:
October 2012
1
I'm having this same issue, same computer I've always used to program the 850. Had to reinstall the MX850 software after getting a new HD. Keep getting this error that Comm Port is in use by another program. Checked and nothing else is using it.
Post 13 made on Wednesday December 19, 2012 at 13:40
Kris
Founding Member
Joined:
Posts:
July 2001
77
They may have changed something in the newer MX-850's. I was helping a friend replace an 850 that wasn't working anymore with a new one. Was able to communicate fine with several older 850's using the non-installer version of the software but it would not communicate with the new remote. Had to use the installer version of the software to communicate with the new remote.
Post 14 made on Thursday August 7, 2014 at 12:16
donnieboutwell
Lurking Member
Joined:
Posts:
July 2011
1
They did change the new mx850's. Download the latest software from urccontrolroom.com. After you reinstall it, be sure to click "live update" from inside the program. This will update the firmware file that is being sent to the remote when you load. This will make it work! But don't forget that little trick - change com port to the wrong one, and then change it back to the right one. That may still be necessary. This is working for me on a macbook pro running win7 pro with vmware. Good luck!
Post 15 made on Thursday August 7, 2014 at 18:02
kgossen
Super Member
Joined:
Posts:
March 2008
3,022
On August 7, 2014 at 12:16, donnieboutwell said...
They did change the new mx850's. Download the latest software from urccontrolroom.com. After you reinstall it, be sure to click "live update" from inside the program. This will update the firmware file that is being sent to the remote when you load. This will make it work! But don't forget that little trick - change com port to the wrong one, and then change it back to the right one. That may still be necessary. This is working for me on a macbook pro running win7 pro with vmware. Good luck!

After waiting 2 years he finally gets an answer. Wonder what he's been doing all this time?????
"Quality isn't expensive, it's Priceless!"
Page 1 of 2


Jump to


Protected Feature Before you can reply to a message...
You must first register for a Remote Central user account - it's fast and free! Or, if you already have an account, please login now.

Please read the following: Unsolicited commercial advertisements are absolutely not permitted on this forum. Other private buy & sell messages should be posted to our Marketplace. For information on how to advertise your service or product click here. Remote Central reserves the right to remove or modify any post that is deemed inappropriate.

Hosting Services by ipHouse