Your Universal Remote Control Center
Philips Pronto NG Family Forum - View Post
Up level
Up level
The following page was printed from


Original thread:
Post 11 made on Tuesday June 14, 2005 at 19:23
Founding Member
May 2002
Same problem for me. At 10:00 a.m. on Sunday I turned on my XM radio. Left the TSU3000 in the charging dock. At 2:00 p.m. I went to turn off the Polk and ... I got some 'flashing' at the top of the screen
but only the hard buttons had any effect. I did all the usual steps of
reset, remove cells, reload pcf, reflash the firmware.

Then I got the awful calibration problem. I use an iPAQ stylus
which always has worked first time. After about 100 attempts
I used my fat finger. After about 30 attempts it suddenly accepted the
calibration. It still did not respond.

Repeated all of the above - but could not get the calibration this time.
I reflashed the last firmware - but that was a failure too.

Soooooooo...... I went to Best Buy and bought a Harmony 659.

30 minutes later I had a less aesthetically pleasing device, but
it worked pretty well. It took me a long time to get the pronto
to where I wanted - and I always thought that the ProntoEdit NG
was an amateur piece of software.

Goodbye Philips. When I lived in the UK I had several Philips and
Philco product including great TVs and a wonderfule BetaMax
VCR. I suspect that Philips TVs and plasmas are great products
still - but the quality of your Pronto remotes (apparently most
of them) based on the hundreds of derogatory posts on this site -
that I shall never risk your company's products again.

Oh, just in case you havn't had any product marketing or customer
service training - the old addage is that if you do a great job your
customer may tell one or two people about you. However, if there
is a problem that is unresolved (or unresolvable) then your customer
may tell 10's, 100's 1000's of people....

Hosting Services by ipHouse