Your Universal Remote Control Center
Philips Pronto NG Family Forum - View Post
Up level
Up level
The following page was printed from


Original thread:
Post 5 made on Wednesday June 8, 2005 at 00:58
Lurking Member
June 2005
I'm having problems with my TSU3000 which sounds similar. Just the other day, I went to use it and none of the touchscreen buttons responded. The hard keys worked fine (ie: I could change the contrast, etc). So I flashed to the lastest firmware (3.6.7) and then was stuck at the calibration screen. I get three points and then booted out. However, it doesn't seem like it matters where I touch, if I touch the center of the screen, it goes to the three points and gives me the calibration error.

I have done everything I can think of including:
1)Changing batteries
2) Reset
3) Downgraded firmware using the pull cable method
4) Re-upgraded firmware (to 2.3.12, 3.1.15 and 3.6.7)
5) Used small styluses, toothpicks, pens, etc to try and be precise.
6) Tried clicking slightly off the circles.
7) Took unit apart and checked monitor ribbon cables.

I did get the thing calibrated once by downgrading to 2.3.12 and then upgrade to 3.6.7, but then I couldn't click on the buttons. It's been over a year since I bought it, but I called support. They told me that I tried everything that they knew and my only option was to send it back for a fee of $160. For that, they send you a refurb unit w/ a 90 day warranty. Hardly seems worth it though.

Anyway, not a lot of information on this problem. Not sure if this is common with the TSU3000 or if I'm the only one. However, if anyone has any input, please feel free to respond. Swiss Merlin let me know if yours is fixed with the firmware or if you continue to have touchscreen issues.

This message was edited by joecentral on 06/09/05 17:03 ET.

Hosting Services by ipHouse