Your Universal Remote Control Center
General Consumer Remotes Forum - View Post
Up level
Up level
The following page was printed from


Original thread:
Post 6 made on Wednesday December 10, 2008 at 20:19
Lurking Member
December 2008
I've had the same issue after I (not a baby) messed up the remote somehow!! The infrared light on the remote stopped illuminating a year ago, but the remote still functioned until I was messing with my system this weekend. I tried pushing both of the green power buttons on the remote at the same time and successfully turned off my receiver, but that was all it would do. However, using some of your guidelines I was able to get my remote working again! With the receiver off I held down the power button on the receiver until the demonstration mode began. I let it go through most of the demonstration (don't know if that matters or not)then I turned off the power button. When I turned the receiver back on it was still in demonstration mode. At that time I immediately turned it off again. When I turned it back on, all factory settings had been restored and my remote worked?! Might have been just dumb luck but it may work for you. Good Luck!

Hosting Services by ipHouse