Your Universal Remote Control Center
RS-232 & IP Control Forum - View Post
Up level
Up level
The following page was printed from


Original thread:
Post 3 made on Monday February 22, 2021 at 07:53
Lurking Member
October 2012
Digging up an old post of mine.
But hey, I solved the problem and anyone else coming here might benefit.

My projector is assembled in May 2018.
In July 2018 viewsonic actually changed their RS232 codes to another version, which is the one written in the manuals.

This took me 2 years and viewsonic europe themselves could not help me.
They even "repaired" the unit saying it was faulty (which obviously it wasn't).
In the end they blamed my software and hardware and they could not help me.
Even though I actually used their own software (vcontroller) and I could partially controll the projector. RS232 is only TX/RX/GND in this case, so if it was hardware related, I would not even be able to send one command and receive an response.

Oh well.. it works now, but next time I'll consider another manufaturer due to the bad support and I had to solve the problem myself..

Conclusion: There is an old library where the codes are like this:
ASCII: *pow=on#
HEX: 0D 2A 70 6F 77 3D 6F 6E 23 0

Hosting Services by ipHouse