Your Universal Remote Control Center
Philips Pronto Professional Forum - View Post
Up level
Up level
The following page was printed from


Original thread:
Post 1 made on Sunday July 26, 2020 at 05:52
Junior Member
July 2020
Hi there,

maybe someone can help me or has a hint for me:

Im still using my Pronto TSU9600 and it still works fine...

After changing my TV i had to update my Pronto Config an that worked well.
I connected the Pronto directly via USB to my Win10-Desktop PC and deactivated several HIDs, so the Pronto-Download worked fine with PEP1 and PEP3.

After updating the Config i probably made a mistake:
=> i uninstalled PEP2 and
=> i updated the Firmware of the Pronto to the Version 7.3.3

Now the Pronto is still recognized by the PC, but i cant download my again updated config to the Pronto.
There is an Error coming up:

ProntoEdit Professional cannot find a compatible Pronto connected. Please check the Connection.

The Connection hasnt changed and i already tried a other USB-cable.
Has anybody a hint for me how to manage the download again?

I already uninstalled and installed the PEP-Versions (1, 2 and 3), but the behavior is exactly as before.
I tried to up- or downgrade the Firmware by using the Firmware-Upgrade-exe, but theres an Errormessage telling me there is no connection possible.
Of course the Pronto ist fully charged.

What i didnt tried yet is a fuly Reset of the Pronto. I fear, i cant upload my config afterwards and so i cant use the Pronto anymore.
Because the Pronto yet works well (but not with the latest config).
Maybe someone has a hint for me or had the same problem and could solve it.

P.S.: Sorry for my english, i am german...

Hosting Services by ipHouse