Your Universal Remote Control Center
UEI Nevo Remote Controls Forum - View Post
Up level
Up level
The following page was printed from


Original thread:
Post 9 made on Wednesday August 2, 2017 at 13:58
Long Time Member
April 2008
On August 2, 2017 at 07:31, JMarcosPG said...
Same registration fail! Did anyone solved this issue? Software is useless without "registering" it!

Hi again. It's probably best to keep your questions/issue in one thread. Anybody who looks at this forum (there aren't many anymore) sees all threads with new posts, so the "shotgun" approach is unnecessary, and just makes it more difficult to follow a line of discussion or troubleshooting.

What version of the NSP installer do you have? And what specifically happens? For example, does the installation appear to complete successfully, but it's only during actual use that you get these pop-ups asking for registration? If so, what action(s)? Or is this a roadblock during the installation itself?

What Windows versions have you tried it on....just XP and 10, as mentioned in another thread?

Hosting Services by ipHouse