Your Universal Remote Control Center
Philips Pronto Classic Forum - View Post
Up level
Up level
The following page was printed from


Original thread:
Post 1 made on Sunday June 26, 2016 at 22:02
Lurking Member
June 2016
I've always had no problem with Windows 7 and my Keyspan USA-19H USB converter, but now with Windows 10, the emulator is freezing, or won't run.

ProntoEdit 4.05 runs, (I tried legacy versions too), and I can upload and download configurations, but the emulator, ProntoEmulator.exe won't run and ProntoEdit freezes and crashes, or gives 'not responding' in task manager.

Apart from the defaults, I've placed it in the root directory, with a 'short' folder name, but no luck.

I've changed Windows Temp variable location to c:\temp, in case long folder names were interfering, and as soon as I did this, it worked...but only once!

I've made sure my IR codes don't have empty names, and they all have 'Learned', etc.

Decompiled/recompiled using CCFTools

Uninstalled/reinstalled ProntoEdit

Used the emulator from the Marantz, Yahama, etc. equivalent: same result.

Tried every combo of the XP, Vista, etc compatibility mode, run as administrator, uac off, virus scanner off.

Put a new pronto.css in c:\ downloaded from here, and tried my old backup one.

What DOES work:
If I copy the RU890 folder to my desktop, and copy my .ccf in there too, I can drag and drop my .ccf onto ProntoEmulator.exe and it runs just won't run from ProntoEdit, nor by 'opening with' ProntoEdit.

After I've done this, I can try running the emulator from ProntoEdit, and ProntoEdit will crash, but the current ProntoEmulator.exe is fine, so it's almost as if it doesn't even try running it.

Thanks to Daniel Tonks, if you use:

it will allow you to change the ccfpicker.ini to
[ProntoEdit v4.05]
Program = C:\Program Files (x86)\ProntoEdit4\ProntoEdit.exe
Emulator = C:\Program Files (x86)\ProntoEdit4\RU890\ProntoEmulator.exe

and then you can 'open with' ccfpicker, and click 'Emulator' and it runs, if your .ccf is in the prontoedit directory.

Hope that helps someone, and if there's a way to run the emulator directly as the default, please let me know.


Edit: You can use EventGhost to find the ccfpicker window, maximise it, move the mouse and click, all automatically in a blink of the eye:

Last edited by quadhammer on June 26, 2016 22:36.

Hosting Services by ipHouse